unable to connect to ebuyer

  chub_tor 19:14 09 Mar 2006
Locked

Has anyone else got this problem today. The status bar sits there saying "waiting for click here" and never connects.

  Graham ® 19:20 09 Mar 2006

I can get Ebuyer and click here

  octal 19:21 09 Mar 2006

Ebuyer seems to be loading here OK, what browser are you using? If you are using Firefox you could try blocking google.com/analytics/ in Adblock.

  octal 19:24 09 Mar 2006

Just a thought, you might be having trouble connecting to google.com/analytics/ through your ISP, which ISP are you using?

  chub_tor 09:27 10 Mar 2006

Tried again this morning and it is still the same and it also happens on the CCleaner update site. It takes ages to load with the notice "Connecting to google-analytics.com" and eventually (5 minutes or more) connects to the ebuyer or ccleaner site. But then it happens on each page so it's not easy to use ebuyer any more. It happens with Firefox and IE so I think that octal's suggestion re the ISP may be correct. I am with f2s and will contact them.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?