Unable to assign IP

  shanema 19:37 27 May 2007


I am having problems trying to connect a machine to my network and was wondering if anyone could help me.

I am connecting the machine via LAN and have DHCP in use however when I try to connect no IP address is assigned. I checked the cable and the DHCP server, by connecting other computers using the same cable and it worked fine.

To try and get around this I tried to enter an IP address manually. I selected a valid IP address and it said that I was connected. However I could still not access the internet and was also not able to connect to any network resources (in particular i could not connect to the router despite being plugged directly into it).

Any help would be most appreciated,

Thanks in advance,


  recap 21:59 27 May 2007

Are you using a Server or just desktop PC's?

  shanema 22:43 27 May 2007


Thanks for the reply. I'm just using desktop PC's connected to a ADSL router.


  postie24 19:28 29 May 2007

Have you checked the auto obtain IP address box and the DNS server box are ticked in internet protocol properties?

  shanema 19:29 29 May 2007

Yes I have. Unforunatly it still either won't accept an IP or isn't being issued one by the DHCP.

  brundle 01:02 30 May 2007

Are you sure there are no damaged pins on the network card itself?

  shanema 13:36 30 May 2007


Thanks for the reply. No i've just checked the pins on the network card and they are all intact. I've also downloaded the latest driver and re-installed it.


  brundle 16:56 30 May 2007

make and model of router? any changes implemented on the router restricting the IP range it can/will assign? does your problem pc show up in the 'connected devices' page when you assign an IP address manually and it reports that it is connected?
is internet connection sharing enabled on the problem machine (by design or accident)?

  shanema 17:00 30 May 2007

The routers is a Netgear DG834GT. The IP range is set to -

The PC doesn't show in the connected devices when I assign it an IP address manually. Whilst Windows says that it is connected I am still not able to connect to any network resources and the other computers on the network can't see it either.

Internet connection sharing is not activated on the machine since no other machines connect to the internet through it.

Thanks again,


  shanema 17:02 30 May 2007

Just as a quick add-on the the above, although the IP range i gave is correct please note that is reserved for another computer on the network.


  brundle 22:44 30 May 2007

You've eliminated the router from the equation as you say it works with other computers, ditto the cable.
Does the PC have a built-in ethernet port or is it a PCI card? Is it picked up by any of the popular Linux distros, or even the smaller ones like DSL - you could try a LiveCD, if it picks up the hardware and still won't connect you have eliminated Windows as the cause too.

Some LiveCDs, smallest first;

Damn Small Linux; click here
Pick a download location, select the `current` folder then `dsl-3.3.iso`

Puppy linux; click here

Slax (easy to incorporate drivers for PCI cards if they're available in the modules section); click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?