Ubuntu 9.1 instalation problem

  immer 10:02 04 Dec 2009

after upgrading via download from ubuntu9.04 to 9.1
my graphics went crazy. Unable to restore from previous. Suspect graphic driver been updated to an unsuitable one. Please advise.
(Have WXP on separate partition on same PC working fine)

  immer 11:01 04 Dec 2009

The screen is so flahing I cannot get my name or password in. What I need to do is somehow reinstall my graphicas driver perhaps but how to do it is the question

  LastChip 23:39 05 Dec 2009

Is your screen flashing all the time right from the start up? (that would be unusual).

If you can get to a menu (as described by Marg7), can you start Ubuntu to a command prompt?

Do you have an Ubuntu "live CD" of any type?

Please let me know and we may be able to progress this further, as it is normally possible to rescue a Linux system from this point.

  immer 10:02 06 Dec 2009

Thanks. 1)on booting from first get menue choice for 3 types of ubuntu plus recovery, the ubuntu memory checker and my wxp system. so far ok. 2) tried all 3 ubunti generic choices (6,6.27-14; 28.16 or 31-14) and all had this, a white ubuntu centre screen symbol still screen ok,3) but then a flashing screen and a text screen type request for a password not like the steady smooth textbox on coloured screen I used to get.4) Trying the recovery screen I have a steady display but end up with text on black screen requests I havent a clue what to do with.
I have a boot cd for ubuntu8.4 which I tried but it wanted to repartition the pc with another system which didn't help so gave up. All help very much appreciated. Thankyou.

  Procrastinus 10:50 06 Dec 2009

Post a query here click here to see if you can rescue the current situation.
My advice would be to download GParted to a CD and boot with the CD in the CDROM. It will show all partitions including your XP one, delete the offending partition and then after rebooting, reinstall 8.4, it will find your XP installation and give you a new GRUB.
Just don't give up there is always someone who will help if they can!

  LastChip 12:37 06 Dec 2009

You'll need to use the text on a black screen; this is actually what's known as a terminal session. It's the underlying operating system, without the Graphical User Interface (GUI), that you will be familiar with.

There are two parts to this recovery.

The first is to know a little about using "vim" - a text editor and the second, is to know how to get to the file you want to change.

You are going to be in a powerful mode, so don't be tempted to change anything other than what I tell you. NOTE: all commands are case sensitive.

First, log in.

Type your normal user name and hit enter (I'm going to abbreviate that to [E] future reference).

Now enter your password [E]

You're now logged into the system.

Next, you need to change to the directory you need to work in, so the command is:

cd /etc/X11 [E]

(note the space between cd and / and the capital X and the ones as in eleven)

Your prompt should now look something like this:

[email protected]:/etc/X11$

NOTE: the $ sign means you are accessing the file as a user, this will change to a # when you start doing the real work as "root" and that's when the potential for damage is greatest.

First, you can backup the file you're about to change; use this command:

sudo cp ./xorg.conf xorg.old [E]

You now need to use a ext editor (vim) to do the work and as you'll be changing a system file, will need to be root. Changing to root in Ubuntu is achieved by using the "sudo" command and after using it, you'll be asked for your password. You also need to access the file to change. You can combine these operations into one command as follows:

sudo vim xorg.conf [E]

You'll now be in the text editor, with the opportunity to change the file, but first, you need to know how to get to the line you need to change. NOTE: if things go pear shaped at any time, hit escape and then :q! and this will take you out of the file without making any changes.

On with the work. Use the arrow keys to scroll down, until you reach the section headed:

Section "Device"

You should see two lines; you are interested in:

Driver "whatever"

Within those quotes, is the driver Ubuntu has loaded for the system and your objective here, is to get the system back to a stable state, to allow Ubuntu to load the proper drivers for your graphics card. With that in mind, you're going to change to a "safe" driver, which enables you to start the system to let Ubuntu load the proper drivers in the normal manner. This is achieved in the following way.

Hit the "Insert" key and note at the bottom left of the screen, you now have "Insert" as a mode of operation.

Use the arrow keys to position the cursor under the final quote and then carefully use "Backspace" to remove the driver (leave the quotes in place). Now type in its place;


so the line should now look like this:

Driver "vesa"

Now you need to write that to the file. This is done by first pressing "Escape", which takes you back out of "insert" mode and then pressing colon wq [E] which looks like this:

:wq [E]

This writes the file and quits the application.

Now use:

sudo reboot [E]

Cross everything in sight and hope it all boots properly.

If all is well, you can now use the GUI to let Ubuntu find the correct driver to load for your graphics card.

Hope that helps.

  immer 20:32 06 Dec 2009

MMM. On the recovery screen have "Resume, clean, dpkg,grub,net root & root." Which should I use please? I tried resume with fault returning, tried "clean" and it did allsorts ending with asking me for my user name & password. It took my username but would not accept my password.....repeated without any joy.
I did see the $(dollar) sign but couldnt get anything to happen....
I think its a wrong graphics file but how to recognise it or what to ask for etc is a mystory to me......any more help greatfully accepted.

  LastChip 21:38 06 Dec 2009

Try using;

User name: root

Password: root

or if that fails, try your normal user name and just hit enter when it asks for a password and yet another alternative is to just hit enter for both user name and password, but I'd be surprised if that worked.

I'm not sure what clean did. It's possible it removed all passwords to let you back in the system.

If this all fails, don't worry, you should be able to use the live CD to correct the problem.

I was reluctant to go down that route, as it may throw up permission issues which complicates matters. But it's not impossible.

  immer 21:51 06 Dec 2009

Thanks for your help. Managed to get it going at last but the graphics drivers Nvidia 173 and/or 185 do not work well on my ubuntu system but windows ok.
Tried the test cycle video mods tester & it sent the thing potty, and produced a big report. Know of a better graphics driver?
It is fortunate I have no vital info on this system just now and was considering a big switch over from windowsXP, but not so sure now.....

  LastChip 00:07 07 Dec 2009

First make a back up of xorg.conf as described above. You will need a different file suffix. I tend to use dates, something along the lines of: xorg.061209 If I want to then use it in the future, I can see the most recent good file date. That file, is effectively the configuration file for your system, so having the ability to go back to a known good configuration file, can be a life saver!

Then, in your terminal, type the following command:

wget -O NVIDIA-Linux-x86-pkg1.run click here [E]

(it's one continuous command with the spaces as seen)

and when the driver package has downloaded, type:

sudo sh NVIDIA-Linux-x86-pkg1.run [E]

This should execute the driver installation.

My own Debian system uses Nvidia drivers, but on installation, insists you exit from the GUI. It's not clear just how you do that, so I wrote this a while back that explains how to do it, click here

If necessary, it should work OK in Ubuntu.

If your previous version worked well, there is no reason why the new version shouldn't be equally as good.

Let us know how you get on and if all else fails, you now know how to recover the system!

  LastChip 00:11 07 Dec 2009

A problem with the command and "click here". I'll rewrite the command inserting curly brackets {, When you use the command remove those brackets.

wget -O NVIDIA-Linux-x86-pkg1.run htt{p://click here{.co{m/Download/{index.aspx?lan{g=en-us

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017