Two Errors I cannot locate any info on

  Chegs ® 02:57 23 Mar 2005
Locked

I have been trying to install a program into XP Pro.I initially tried V1.1 of the prog and keep getting these errors....


DetectSpeechVirtualDir.

ERROR: ADsGetObject Failed


GetWWWRoot.DDC1E6EE_98CB_440F_8F3C_FED7FC44D174.

ERROR: ADsGetObject Failed

when running "Setup" with logging enabled.

Anyone suggest a way round these errors,or even an explanation in laymans terms of what they mean.The "DetectSpeechVirtualDir." looks like its missing the Speech Virtual Directory,but surely this is only going to be created once the app is installed,not something that can be added beforehand?

  Diodorus Siculus 07:42 23 Mar 2005

Is the program meant for XP? It seems to me like some sort of coding error.


Make sure that you have all the relevant updates for the OS and give the sytem file checker a spin:

start

run

sfc /scannow

  Yoda Knight 08:27 23 Mar 2005

try installing it whilst connected to the internet. I'm not sure but that code looks like its trying to access somthing from the net

  Chegs ® 09:27 23 Mar 2005

The program is able to work in these OS's...


Microsoft Windows XP Professional Service Pack 2

Microsoft Windows Server 2003 Standard

Microsoft Windows Server 2003 Enterprise


The prog is unable to install if ALL the updates aren't there,there is a seperate "Setup" app to check these,and this logfile shows it runs through a host of checks(far to many to include in PCA)

Action 02:30:10: SetupInitialization. Dialog created


Action ended 02:30:10: SetupInitialization. Return value 1.


Action start 02:30:10: HasIE6.
STATUS: Setting HAS_IE_6 to #1


Action ended 02:30:10: HasIE6. Return value 1.


Action start 02:30:10: HasLatestEI.
STATUS: Setting ENT_INST to #1


Action ended 02:30:10: HasLatestEI. Return value 1.


Action start 02:30:10: DetectIisService.


and so on.


I doubt if it needs a net connection,as if IE is running,the setup stops until you close IE.

Thanks both for the suggestions,anyone else want to have a go?

  Yoda Knight 11:02 23 Mar 2005

I meant just the connection, not necessarily have IE running...

It was just a thought anyway, based on "GetWWWRoot", "HasIE6" & "DetectIisService"

Good luck with that...

  Chegs ® 11:13 23 Mar 2005

I'm starting to get seriously fed up of this.I had to add IIS to the OS,but trying to get it to "start" is bugging me.I typed the command...

net start w3svc as advised click here

but all I get is

Attempting stop...
Internet services successfully stopped
Attempting start...
Restart attempt failed.
IIS Admin Service is disabled

C:\SpeechSDK\SASDK>net start w3svc
The service name is invalid.

Looks like I'm in for a hell of a day. :-)

  Chegs ® 14:12 23 Mar 2005

"GetWWWRoot", appears to be referring to missing web pages(I added a default.htm web page to this folder)having found this page from google...

click here


To publish content on your Web site

Create a home page for your Web site. See Choosing an Authoring Tool for more information on available tools used in Web site creation.
Name your home page file Default.htm or Default.asp.
Copy your home page into the default Web publishing directory for IIS. The default Web publishing directory is also called the home directory, and the location provided by Setup is \Inetpub\Wwwroot.

  Chegs ® 14:31 23 Mar 2005

And a bit more google got me...

To create a virtual directory

In the Internet Information Services snap-in, select the Web site or FTP site to which you want to add a directory.


Only problem is the "Internet Information Services snap-in" refuses to allow me to start it.I have tried from DOS/Computer Management and all I get is a message alerting me to its refusal to be started.Looks like I'm off to wipe/reinstall C:\Windows apply all the updates again and see if it will allow me to restart IIS then.If it still refuses,then I will be back in PCA to ask for help.

  Chegs ® 13:04 24 Mar 2005

Reinstall of XP cured it,thanks to those who responded.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

50 best online Adobe XD tutorials

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?