Trying to update Foxit Reader

  polymath 16:20 20 May 2012

Foxit Reader recently offered an update for my desktop computer, but it wasn't a convenient time for it. I'm now trying to update it manually, with Help - Check for Updates Now.

The box shows there are 3 updates available; Basic Module, Service Module & Reader Update. I can highlight them (1 at a time), but all I can do with them is set automatic checking for updates to weekly or monthly. Nothing appears in the Size & Description boxes, and the 'Add' button is greyed out.

I successfully updated Foxit Reader in my notebook computer, using the same option. Maybe the next step is to find the website?

Vista SP2, Firefox 12 (both computers).

  lotvic 20:24 20 May 2012

No help really, just that mine's the same. Using Version 4.2 I suppose only thing to do is to install a newer version, I think the latest is Version 5.

Make sure you watch out for eBay shortcuts and uncheck them also don't install the Ask Toolbar and remember to click on 'Decline' Foxit Search Bar (which will install Ask - sneaky that it's offered twice)

I've decided to leave mine on V4.2 for now.

  polymath 20:27 20 May 2012

Sorry - meant to say it was in the notebook that Foxit offered the update! (I subsequently tried to update the Reader in the desktop).

Problem solved; I found at the Foxit website that the desktop's version of Reader was too old to update, so it was a case of uninstalling it then installing the latest one (simple, once I knew!). The version from which I updated in the notebook must have been more recent.

Wonder how the previous version in the desktop knew it was too old to update? And why it didn't just say so? (Though that's only academic now).

  lotvic 20:34 20 May 2012

Permanent 'senior moment' perhaps. lol. Maybe I should look to update mine as well, thanks for info.

(you can green tick thread 'Resolved' by clicking on a big grey tick to the right of any of the posts - it will turn green - next time page is refreshed, Thread will be marked 'Resolved'. No need to post any text)

  polymath 21:28 20 May 2012

We seem to have cross posted, lotvic! Thank you for the info. The version I was trying to update from was 3 (no wonder 5.1 showed lots of nice new features)! I did decline the Ask Toolbar and the Foxit Search Bar, emphatically and probably twice. I seem to be forever warding off toolbars, and attempts to change my default programs.

I must have slipped earlier today, when installing Ashampoo Photo Commander (or else there was no opt-out); the Ashampoo US Community Toolbar duly appeared, with the usual mixture of irrelevant links and ones I have bookmarked anyway (another one for the drop-down list of disabled toolbars!). But I guess it's a small price to pay for free use of software.

  lotvic 21:33 20 May 2012

Ta, I'll update mine later this week when more time and patience ;-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?