trying to install a free copy of Knoppix

  popgeorge 17:16 18 Jun 2004
Locked

I have been using Me and XP and thought I would try out the Linux system. A copy of knoppix will load as far as configure, then fails to detect usb devises. If I enter the failsafe mode it will then continue to install to the final stage but the keyboard has limited use and the mouse is dead. Although I have very limited knowledge, a pointer in the right direction would be appreciated.

  GaT7 17:43 18 Jun 2004

Try the Knoppix forum - click here. Good luck, G

  popgeorge 19:06 18 Jun 2004

thank you for the info, will give it a go.

  keith-236785 20:53 18 Jun 2004

Knoppix (though i believe it can be installed to your hard drive) is meant to run from the cd. to use linux, set your pc to boot cdrom first, then put the knoppix cd in the drive and restart your pc, when your pc is restarting it will boot to cd (you might have to press a key to boot from cdrom) and it will continue to load fully.

if you have already done this and it doesnt work you might have to burn the cd image again or download it again.

if you are trying to install to hard drive then i cant help as i have not tried it.

knoppix running from the cd detected all my hardware and internet connection (broadband) and was a delight to use as a first look at linux.

  Chegs ® 20:59 18 Jun 2004

I have an older "spare" PC,it allows me to tinker in linux without taxing my limited knowledge.I tried d/l the latest "Run from CD" Knoppix and running it on my "main" PC,it doesn't even get past "Detecting hardware" as it still hasn't been told about SATA yet. ;-)

USB in linux has often been a hassle for the "noob" to linux,in fact its probably a hassle for intermediates too. ;-)

I would try another distro,Mandrake/RedHat/Suse as I have tried installing these on my previous PC,and apart from HP refusing to release a scanner driver for linux,most other USB hardware worked okay(was missing the MFG driver extras tho')

  popgeorge 07:03 19 Jun 2004

The installation stalls at.....

Auto configuring devises
Insmod. Already exists
Insom/lob/modules2 .4.24.-xfs/kernal/drivers/input/input, o failed
Insmod:usbbkd failed

At this point no further action can be taken. This is a copy of a knoppix cd supplied with a Linux Mag, I have previously tried with a downloaded copy burnt with nero, with the same result. The idea was that I would be able to check out the system in the event of a HD failure. I am using a two year old p.bell P4 1.7 256 RAM, and would have thought this would have compatible components fitted.
Thank you for your replies,

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?