Trying to get spellcheck to work on Opera in Linux

  octal 20:01 16 Feb 2005

As the title says.

I've tried looking in the Opera forums and the Xandros forums, nobody there seems to know.

It should find Aspell, but it doesn't. It used to work OK till I reinstalled Linux last night, 'cos I messed it up, now it doesn't work.

I've checked the file location and Aspell seems to be installed were it should be on /usr/local/lib/aspell but I've got a feeling there's something else I've got to do. but I'm not sure what. Any ideas please?


  Pesala 20:10 16 Feb 2005
  octal 21:29 16 Feb 2005

Thanks for the reply, yes, as I said in my first post I had checked on there, its mainly for Windows and the odd Linux post doesn't seemed to come to any conclusions. Only wish I could read Serbo-Croat, some of those posts might hold the clue.

  octal 12:12 17 Feb 2005

Xandros are having major problems with their SP1, so its probably related with my problem.

click here

  Dennis Goycoolea 00:12 18 Feb 2005

opera.linux is all about Opera for Linux. :)

If it helps, it's not just you. I have a Mandrake 10.1 Official box here, and Opera 7.54 installed. GNU Aspell is installed -

$ which aspell

And works, I've checked it in Vim. It's not working properly with Opera though: 'Check spelling' is always greyed-out. Naturally, Opera doesn't tell you what's the problem if you start it from a terminal.

How about running an strace? Let us know if you get to the root of the problem, it's piqued my interest.


  Dennis Goycoolea 00:14 18 Feb 2005

Sudden 'brain attack' just after I posted. You mention /usr/local/lib/aspell, but what if Opera expects dictionaries in /usr/lib? Create a symlink there, perhaps that'll fix it.


  octal 08:00 18 Feb 2005

Thanks Dennis for your help. I've had a closer look this morning, it seems like Aspell hasn't been installed fully and there are no dictionaries installed.

I downloaded Aspell again, but its going on about compiling them with C++, I'm not into all of that, so I'm ignoring Opera for the time being for anything that I need to check my duff spelling with.

Firefox gets corrupted when I try and install some of the extensions, which includes Spellbound since Xandros have sent a SP1 out, so that's off the menu at the moment till they get it fixed.

At the moment I'm using Mozilla 1.7 which Spellbound works fine, but its not as configurable as Firefox, also Konqueror works OK, its a good job I've got a choice of browsers!


  Dennis Goycoolea 11:53 18 Feb 2005

You shouldn't need to compile aspell from source, just grab the Xandros aspell package. Remove the current install & re-install it. Usually I never reinstall anything under Linux, but it seems fair enough in this case if bits of the package are missing.

Oh, and check if Xandros keeps aspell dictionaries in seperate packages, wouldn't surprise me.

What is it with these Xandros 'service packs' breaking stuff, anyway? It sounds awful; a case of copying MS Windows going a little too far.


  octal 12:05 18 Feb 2005


I've managed to install the English dictionary by following the instructions in the readme file and check in control centre and it picks up about 50 different flavours of English!

All I've got to work out is how Opera reads Aspell, I've found a folder called /usr/lib/opera/7.54-20050131.5 which contains a file called I've tried a symbolic link to /usr/bin/aspell from that folder, no joy.

and one in /usr/share/opera/ini which is called spellcheck.ini, I've opened that file and it says:

Opera Preferences version 2.0

; Do not edit this file while Opera is running

; This file is stored in UTF-8 encoding

[Spell Check]

Default Language=en

Default Encoding=iso8859-1

Without the carriage returns between the lines, so I'm stumped at the moment.

I seemed to remember I had this problem last year if my memory serves, I just reinstalled Opera after doing something and it worked, trouble is I can't remember what!


  Dennis Goycoolea 19:37 18 Feb 2005

Hi again,

Check this out: click here

It says you need to edit the script which starts Opera, /usr/bin/opera. I tried adding the location of the aspell libs myself, to be honest it _still_ didn't work, but it might for you.

I've been trying to make it work with aspell (aspell-0.50.5-3.1.101mdk) from Mandrake. I suppose /usr/lib/aspell is the right place in this case, but who knows what Opera expects from me.



  octal 21:55 18 Feb 2005

Thanks Dennis.

That link is interesting, I have read through it and like you, everything seems to be where it should live, all I had to add was the ":/opt/aspell/lib
export LD_LIBRARY_PATH" to part of the script to complete it.

It still doesn't work in Opera, its interesting that Aspell now works in the other applications that require Aspell, so it does work, so it looks like an Opera problem.

I think I'll leave it for now, but thanks for your help and support, its much appreciated. Its been an interesting exercise, I feel I'm a bit more up the learning curve with Linux!

Kind regards


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?