Troublesome USB Flash drive

  malynx 22:16 14 Mar 2011

I have a USB Flash drive that I cannot get to work.
I bought it some time ago and am pretty sure I have used it to store a text file, but it hasn't worked ever since.

I tried to use it on a college PC (Windows Vista) but it wasn't recognised - a college tutor was busying about so i couldn't properly take note of what was or wasn't happening further than it wasn't happening fast enough for the tutor.

Recently I needed to use the drive again but plugging it into my PC (XP Professional) doesn't seem to do anything - the "new hardware detected" symbol appears in the systray as it should, and the LED on the device flashes continually, but the dialog box asking what I would like to do doesn't appear. The drive (F:\) doesn't show in Start Menu > My Computer either.
When I click to "Safely remove hardware" it asks if I want to stop the USB mass storage device - generic volume F:\ - USB memory device, (so it seems my PC does recognise it) however choosing to do so results in the cursor turning into the egg-timer icon and the device never seems to be stopped. I had to power down (by hard boot in the end!) in order to stop it.

I also have a laptop (Vista) and have the same problem with this Flash drive. I left it connected and running to see if it eventually recognised the device, instead Windows Explorer hung, and then my display was only my desktop background picture: no toolbars, no icons, no right-click function. Eventually I pulled out the Flash drive and everything instantly restored!

I have since bought another flash drive and have no problems at all with that (touch wood), so it doesn't seem to be a problem with the USB port nor the drivers.

Is there anything I can do to repair this Flash drive?

Thanks in advance.

  Fruit Bat /\0/\ 22:25 14 Mar 2011

click here

try using the HP USB drive to find and format the drive.

  malynx 23:01 14 Mar 2011

Sadly that hasn't worked, Fruit Bat.

The Flash drive isn't detected and doesn't appear in the drop down box. Rescanning doesn't loacte it either :(

  robin_x 23:29 14 Mar 2011

You could try USBDeview. I have seen it suggested many times. Mind you didn't work for me. My ports always seem 50/50.

click here

Watch out you don't disconnect USB Mouse/Touchpad.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017