Trouble with a rebuilt PC

  jessej 11:26 28 Sep 2004

Hi there.
At last I have got around to rebuilding a computer, it has been done using obsolete, but working, parts left over from upgrading. The computer I am using now contains absolutely nothing of my first, including the case, so what I had left was everything from the old one but they needed putting back together again. The idea behind doing it this way was that if I blew anything up then it was not going to damage my pocket. Having got that out of the way, I'll come to the problem.
I had no trouble assembling everything except for when it came to connecting various cables, namely those to the block on the motherboard labelled Power LED; Speaker;HDD led; Reset Switch & Power Button, pins 1 to 22. There is no indication of which way round to connect them so I done it by plugging them in the way they were already bent, or the easiest. Its a PC Chips Socket 370 M758LMR+ board.
Next I set up the BIOS, which showed the date as March 1999, and no trouble there, it recognised everything and everything was as per the manual.
And after that everything went pear shaped. The messages on screen were listed in the order that follows:
Load Error!
Press a key to reboot
Searching for Boot Record from Floppy...Not Found
so I pressed a key and got the following:
Drive Not Ready
Insert Boot Diskette in A
Press any key when ready

Searching for Boot Record from CD ROM..Not Found
Searching for Boot Record from IDE-O.. OK

Load Error!
(repeat all above)

Non System Disk or Disk Error
Replace and strike any key when ready

Boot Error!
(repeat everything as above)

Restarted then got CMOS settings are wrong so had to go into BIOS and set everything up again, date was back to March 1999.

That's about it, I fitted a new battery before I started so don't think that has anything to do with it. My main suspect is the hard drive, other than a couple of blinks, the HD light stayed off.

Sorry it has been so long but I thought I should put down as much as I knew. Any/all help gratefully received.

  georgemac 11:33 28 Sep 2004

looking for something to boot from

either a boot floppy - put one in the drive

a bootable cd rom - w98, me or xp - put the cd in the cd-rom drive

assuming the hard disk has nothing on it so it cannot find boot record there

if the floppy light is on all the time, reverse the cable connector - red strip to the left looking down from the top.

  ventanas 11:44 28 Sep 2004

Looks like its found some kind of boot record beause the IDE-0 is ok. Has the old hard drive still got an operating system on it? If so get rid of it and start again.

  jessej 11:56 28 Sep 2004

Thanks for your very swift replies.
I put a flopy in, a boot disk downloaded from
I tried putting a CD in, first the original Recovery Disk. The only option it would allow was to restore from a back up, which it said it had found. Very strange as the drive had been reformatted. As that did not bring any results I then tried a Win. 98SE CD, that wouldn't do anything as it told me that the OS was already installed.
The Floppy Drive light is not on all the time so that is connected correctly. Its the Hard Drive light that is not coming on, except for a couple of very fast blinks measured in micro seconds.
As to getting rid of the old OS, I can't get access to anything to allow this like a command prompt, also the old recovery disc will not give me the option of Format, it insists that I restore from a back up. The option is shown, I just cannot select it.

  ventanas 12:04 28 Sep 2004

If you boot from your floppy does that not drop you at the A:\> prompt? Can you not then type either fdisk or format C:?

  Noelg23 13:39 28 Sep 2004

exactly what I was going to say ventanas...but you beat me to it...I would go with that...thats what I would have done...

  jessej 14:26 28 Sep 2004

That, at least, is part of the problem, it will not recognise the floppy at all, all I get is the message >Non System Disk or Disk Error. Replace and strike any key when ready<
I've now downloaded another boot disk for 98SE from click here, but haven't had time to try it yet. Whether that makes any difference is debatable as the disk I've been trying to boot from came from the same place, though admittedly, a long time ago, about 12 to 15 months if I remember right. Just to try something different, I've downloaded 3 in all, one for 98SE; one for 98SE OEM (both from and yet another from for 98SE.

  JonnyTub 14:27 28 Sep 2004

is all your devices listed and recognised in the bios

  jessej 22:04 28 Sep 2004

Yes, at least when I set the BIOS up, which I have to do almost every time I switch the computer on. It seems as though it cannot retain its memory, which is another possible indicator as to what is wrong. As to the floppy Boot Disks mentioned in my last post, they are not recognised either, and so don't work.

  Fruit Bat /\0/\ 22:17 28 Sep 2004

If BIOS not retaining info (very likely as March 1999 date) then renew the CMOS battery, then reset the BIOS for your correct HDD boot order and MPU speed etc.

  Lady Lara 22:25 28 Sep 2004

Remove any Floppy Drives from Mobo as well as any CD/DVD drives. in IDE port on mobo put a cable to HDD and try that way to see if it picks up. If not try an different cable in IDE 0 or 1.
Trial and error here. Also check bios settings so that primary boot is HDD.

As you add the floppy etc change bios to default to FDD first and HDD second.

HDD is better running on it's own cable from past experience.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?