Trouble with IIS in xp pro

  iamthewalrus 16:15 26 Jun 2007
Locked

Hi, I am trying to setup a webserver on a computer on my network. I have a Safecom SWBARR-5400 router with my PC and the webserver (running windows xp pro) connected. The webserver has a static IP- 192.168.1.3. IIS is installed and appears to be running correctly, when i type click here into the browser i am shown the pages that came with IIS, i can even get a php test page working. The problems creap in when i try to access my webserver using the computers IP address. I type click here into the browser, it takes ages and hands me a login box and when i cancle that, a "You are not authorized to view this page" page! I also have a port forward setup on my router to send incoming port 80 trafic to 192.168.1.3 (the webserver) when i goto the WAN ip address (the one reported by click here - 80.4.194.175) i get an "Internet Explorer cannot display the webpage" page. I have been going in circles for days- does anyone have any advice- its as if IIS isn't allowing access from my ipaddress. Thanks for any help or advice.
Ewen

  P1d 09:03 27 Jun 2007

What happens if you go to click here this is the ip equivalent of click here

Do you have DNS & WINS setup?

  iamthewalrus 16:48 28 Jun 2007

127.0.0.1 works, same as localhost. Re: DNS and WINS, i am unsure how to set these up so probably haven't! how do i go about doing this? Thanks for the quick response and help! Cheers, Ewen

  iamthewalrus 11:23 01 Jul 2007

oops! actualy, 127.0.0.1 does not work, my mistake, i thought it did, probably because all these number ae scrambling my brain! so, localhost works, 127.0.0.1 does not, neither does 192.168.1.3 or the WAN ip, 80.4.194.175.

its like it doesnt like IP addresses!

sory for my cock up,

cheers for all ur time so far

Ewen

  P1d 08:44 02 Jul 2007

Try setting your dns ip address to your webservers ip address.

I've not got the exact settings to hand but it will be under the properties of your iis on winxp.

P1d

  iamthewalrus 10:51 02 Jul 2007

ok, i changed the webservers primary dns to itself, don't know if i did the right thing but i went into network connections>went into properties of the LAN connection> then properties of tcp/ip and changed the primary dns there to 192.168.1.3.

unfortunatly this still doesnt work, same problem as usual.

it wants a username and password and i want it to allow access to everyone.

  P1d 12:57 02 Jul 2007

I think you need to enable anonymous access.

Try this article if you don't want to enable anonymous access. click here

  iamthewalrus 11:54 03 Jul 2007

P1d,

First, thanks for all your help so far, you've given a lot of your time to help me and i appreciate that alot! The article link I think provides the cause of my problems:

Internet Explorer must consider the requested URL to be on the intranet (local). If the computer name portion of the requested URL contains periods (such as click here and click here), Internet Explorer assumes that the requested address exists on the Internet and does not pass any credentials automatically. Addresses without periods (such as click here) are considered to be on the intranet (local); Internet Explorer passes credentials automatically. The only exception is addresses included in the Intranet zone in Internet Explorer.

This would account for it working when loclahost is used but not with 192.168.1.3

I realy don't care who views my website, and thought i had annonymous access enabled. how do i let anyone view the pages on my webserver?

soryfor being a bit of a noob, web servers are quite new to me and im a bit slow on the uptake!

cheers again

Ewen

  P1d 14:38 03 Jul 2007

No problem at all, it's a long time since I did anything on iis so you'll have to excuse my vagueness!!

I'm glad the links I provided helped a little.

Here's some notes I've found, I hope it points you in the right direction;



- Start Internet Services Manager from Administrative Tools.

- The computer will appear under Internet Information Services. Right-click on the computer and choose Properties.

- Select Master WWW Service in the drop-down, then click Edit....

- Select the Directory Security tab.

- Under Anonymous access and authentication control click Edit...

- In the Authentication Methods form, make sure only Anonymous access is checked, then click Edit....

- The default username will be IUSR_NAME. This needs to be replaced this with NAME\IUSR_NAME where NAME is the computer name. Either type it in manually or use these steps;
a. Click the Browse... button.
b. On the Select User form click the Advanced... button in the bottom left.
c. Click the Find Now button in the middle-right of this form.
d. Select IUSR_NAME in the user list at the bottom of the form, then click OK
e. Click OK to dismiss the Select User form.

- Uncheck Allow IIS to control password. (This is important!)

- Click OK to dismiss the Anonymous User Account form.

- Click OK to dismiss the Authentication Methods form.

- Click OK to dismiss the WWW Service Master Properties form.

- Click OK to dismiss the Computername Properties form.

  iamthewalrus 22:40 04 Jul 2007

My hat has been removed towards your general direction P1d! It worked! Thanks so much for all the help! Unfortunatly I am going to have to trouble you for a little more info! sory!

I need to allow some sort of write access on the server. Basically, i have an asp application which writes what the user inputs to a text file. how can enable write permission from this asp page to the server.

Cheers

  P1d 11:13 05 Jul 2007

No problem, that's what we're here for. I'm glad it's all worked so far for you.

It sounds like you will need to grant ASP.NET write access to the file.

Locate the file in explorer and right click, choose "Properties" and select the Security tab. Click the "Add" button, highlight the ASP.NET account, and tick the relevant boxes for the desired access.

Note; if the Security tab doesn't appear you will have to disable simple file sharing. To do this, open any windows explorer window, click on "Tools", "Folder Options..." go to the View tab. Scroll to the bottom of the list and untick the "Use simple file Sharing (Recommended)" checkbox then click on "Ok".

Good luck.
P1d

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires