TOSHIBA USB 3.5"-HDD giving code10 error

pls help, my TOSHIBA USB 3.5"-HDD ( external hard drive ) is giving code10 error in device manager , windows xp

  birdface 07:55 10 Jul 2008

click here= Have a look until someone can help.

  Fruit Bat /\0/\ 19:20 10 Jul 2008

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
or
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

Also make sure the external power to the drive is switched on.

found the box but no set up disc at all, can we assume this is a usb problem rater than hard drive loss ?

  Fruit Bat /\0/\ 19:57 13 Jul 2008

What do you mean found the box?

You do not need drivers for an external drive on XP.

HAve you connected the external power supply for the drive?
Is the drive detected when you plug into a USB port?

yes and yes, device manager shows code10 error

ran your drive clean also, thanks for that

  Fruit Bat /\0/\ 20:32 15 Jul 2008

Please give exact message and where it appears in device manager i.e.

Disc Drives - toshiba 123abc - code 10

I'm imterested in exactly where it appears in device manager USB mas storage device or just under drive this will tell if its a USB connection problem or the drive is faulty.

hi fruit bat, ok box - i meant the box it came in as i thought there was a disc, found the box but no disc, when i plug it in to a usb xp sometimes goes bong bong and sees the drive, not always, then i get a balloon saying problem with hardware , device may not work,
when i go in to device manager it shows under usb devices as toshiba mass storage with a yellow circle and black question mark next to it, in device properties it just says code10, ive tried this on different usb's inc straight in the back of the tower, ive also tried the drive on other peoples towers, same story, xp sometimes recognises it.........pls pls help, it has all my back up on it

  Fruit Bat /\0/\ 21:41 23 Jul 2008

Its looking like a faulty drive enclosure.

you need to open it up and check the connection from the board to the drive.
make sure
data cable (and power cables3.5 inch drive) fully connected.

are the files likley to be intact or worst case recoverable pls

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?