system restore wont work

  biker24 16:02 03 Mar 2006
Locked

system restore has stopped working on my windows xp, here is the message I get,
faulting application rstrui.exe, version 5.1.2600,
faulting module kernel32.dll,
version 5.1.2600.2180,
fault address 0x0001eb33.
can anyone help?

  skidzy 16:04 03 Mar 2006

Have you tried turning system restore off,reboot and turn it back on.

Beaware you will lose any recent restore points.

  biker24 16:19 03 Mar 2006

yes I have, I get the same fault?

  Pine Man 16:27 03 Mar 2006

Try re-installing System Restore as follows:-


Go to Start - Run and type %Windir%\INF then press enter.

In Windows Explorer go to Tools - Folder Options - View Tab and uncheck “Hide extensions for known file types”.

Find the sr.inf file, right click on it and select Install.

If the Files Needed dialog box appears, click Browse and point to the i386 folder on the Windows XP CD or to the i386 folder on the hard drive, if it exists, or for systems updated with the Service Pack 2 CD or Downloaded from Microsoft, browse to the C:\Windows\ServicePackFiles\ folder.

  surfmonkey #:@} 16:31 03 Mar 2006

goto C:\Windows\System32 and rename ssrstr.dll to ssrstr.old.
Window File Protection should replace it.
Next goto C:\WINDOWS\system32\Restore and rename rstrui.exe to
rstrui.old.
It should also be replaced.
now reboot and try system restore

  blanco 17:39 03 Mar 2006

Sorry to butt in, I just wanted to add my thanks to Pine Man.

My System Restore has been defunct for some months now and I tried a number of suggestions without any success and shied away from a reinstall of XP.
Your repair instructions worked a treat after a couple of requests to find additional files on the original XP CD-ROM.

A very worthwhile addition to the Helproom.

  rawprawn 20:03 03 Mar 2006

Start/Run/type sfc /scannow (watch the space) you will need your XP CD. It will rectify the missing/corrupt files.

  biker24 14:11 06 Mar 2006

I cant find ssrstr.ddl, surfmonkey are you sure it`s correct?. also I tried what you suggested pine man, but it did not work.

  surfmonkey #:@} 14:17 06 Mar 2006

what pc do u have have you installed sp2 lately?

  biker24 14:26 06 Mar 2006

I have an advent 3511,pentium 4 2.80 ghz, also I installed sp2 about a year ago.

  surfmonkey #:@} 14:31 06 Mar 2006

i have a conpaq when i nistalled sp2 after a format i had to also install a manufactures patch from the compac site maybe theres possibly a patch for th advent pc just a thoght

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?