System Restore stalls

  Loth 14:08 14 Oct 2006

Some time after sorting a virus problem (Smitfraud) I noticed that System restore was hanging. Coincidence?? System Restore points are being created normally, program starts without problem and I can reach "Confirm Restore Point Selection". When I press 'next' to start the restore, there appears to be some brief activity and then nothing. I have left the PC running at this point for up to an hour to see if anything happened - but zilch. Could it be that SR still thinks I have a virus and is refusing to go back to what it considers is an infected date?
(Running Win XP with SP2 and PC is otherwise acting normally and virus-free. )

  rawprawn 14:43 14 Oct 2006

Turn System Restore Off and reboot, then turn it back on and see if it works then (You will lose all your restore points.)If it doesn't work after that run a system file check

  Loth 15:39 14 Oct 2006


Turning system restore on/off does not help; it only clears previous restore points. I also tried Safe Mode to see if that made any difference - it didn't. Registry Mechanic does not pick up anything significant. Clicking through Administration Tools/Computer Management/Event Viewer/System gives a recent message against "sr" of System Restore monitoring was enabled on all drives" but the problem has been going on for some time. Can you expand on "run a system file check", please? I know enough about computers to be dangerous but need a prod in the right direction now and again. Thanks.

  johnnyrocker 15:51 14 Oct 2006

start/run sfc /scannow and have xp disk ready for when asked.


  rawprawn 16:05 14 Oct 2006
  Loth 17:11 15 Oct 2006

Rawprawn/johnnyrocker - thanks lads but still no go. I ran scannow and the window appeared, the bar progressed from left to right and having gone as far as it could, the window disappeared. I assume this indicated it was happy with what it found? Restarted, closed off all other programmes running, started SR, got as far as usual at "Confirm Restore Point Selection", pressed next, activity light blinked for a few seconds and then - nowt. I note that in "Select Restore Point" window, system restores are recorded for dates that I have made attempts. It just does not seem to recognise that the process was uncompleted each time.

  woodchip 17:17 15 Oct 2006

Have you tried a Restor from one of the dates?

  Loth 19:06 15 Oct 2006

Woodchip, sorry but I don't understand the question. I've been trying to restore from every date that is highlighted as a restore point.

  woodchip 19:27 15 Oct 2006

Sorry if it's not working then You have problems with Restore that can only be solved by turning Restore off then back on. You will though lose the Restore points, But these are no good as they do not work. It must be corrupt. Only the above will get it back in working order. If you still then have other problems post these to see if they can be resolved by other means. Start a thread for each problem.

  rawprawn 19:45 15 Oct 2006

He has already tried turning SR off and the on again with no luck. The only other thing that I can suggest is a Windows Repair.
click here

  Loth 20:05 15 Oct 2006

rawprawn, thanks for suggestion. I will backup all the irreplaceable stuff just in case and give it a try. Will let you know outcome.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?