system restore missing - xp pro 64 bit

  howard64 14:39 13 Aug 2009
Locked

I have just started using xp pro 64 bit and found that system restore is missing. There is no mention of it when you right click on 'my computer' then properties. Nor is it showing in 'run - services.msc' - Is it possible to get it to run or must I do without it. I must say I haven't used it on any pc for some time but like to know it is available. I normally use Acronise if I need to go back.

  Batch 18:27 13 Aug 2009

Personally, I wouldn't worry. Like you I use Acronis TI. Switched off System Restore at the first opportunity when installing OS and have seen absolutely no value in having this unreliable overhead running when I have trusty TI in the wings.

  GaT7 18:34 13 Aug 2009

Try this click here.

Many different things to try here as well click here.

Batch, I like System Restore because it's good for a super-quick restore if a failed driver/dodgy program/similar has messed-up things. Image restorations are usually best for a total/near-total disaster. G

  Batch 18:43 13 Aug 2009

Restoring my TI system image takes about 3 minutes to run and my experience of it is that it's been 100% reliable.

Whereas past experience with System Restore is that it can hang, it doesn't do what it says on the box (i.e. the results can't be 100% relied upon - sometimes it works, sometimes it doesn't - even if it tells you when its failed, it's still NBG).

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires