System restore is eating my disk space

  JimX 18:30 01 Sep 2004

I’ve moved this problem here from the SP2 forum because I’m not sure if it’s directly related to SP2.

I’ve tried and failed four times to install SP2 onto my XP Pro laptop. This led to me trying five system restores over the last week or so. The first three completed successfully; the fourth looked like it had but then on reboot said it hadn’t because the power had been disconnected; when I tried again, system restore eventually said it couldn’t complete because there wasn’t enough disk space.

That’s because over the same period the amount of free space on my drive has dropped from 80% (of 56 Gb) to 5%. In other words over 40 Gb has gone. This has happened in big chunks after each restore.

The restores took longer and longer. The final, failed, one took over nine hours.

I don’t know if this is relevant but I think I’ve also got a new directory called Windows.0. It’s 488 Mb and contains about 3,500 files.

I’ve given up on SP2 for now but I would quite like my disk space back. All ideas very gratefully received.


  Dorsai 18:50 01 Sep 2004

I would start by checking for temp files.

look at c:\windows\temp

how big is it?

search for files, and enter 'tmp' and ditto for 'chk'

i am guessing, but i wonder if the temp folder is full of bumf, or you have loads of check disk stuff that needs deleting.

Maybe you have loads of *.tmp files and/or *.chk files.

IE. you have loads of tmp files that need deleting (*.tmp), or loads of check-disk found lost cluster (*.chk) ditto.

generally these can be deleted with out a care in the world.

try and post back?

  JimX 19:14 01 Sep 2004

Temp file is tiny - 24 Kb. Altogether I can only find 30 .tmp files and four .chk files.


  Dorsai 19:55 01 Sep 2004

well i would delete them any way.

But the space has gone somwhere...

The max size i can set system restore to use is 12%, so what for you?

control panel>system>system restore>settings

search for 'log' files. very long shot, but perhaps a *.log file how huge....i am running out of ideas to suggest.

if you only have one drive (C:\) then open it, right click and select arrange by size.

on the tool bar, set view option to details. Any file(s) really massive, of, lots of files with very samey names....file1.*** file2.*** etc, or file.1, file.2 file.3, get the drift?

for the folders right click on them each, one after the other, and pick properties.

Can you see which file or folder is hogging about 40 Gig?

  Dorsai 20:08 01 Sep 2004

I'm off now. dinenr ready.


  JimX 21:05 01 Sep 2004


Thanks. Hope dinner was nice. Had mine too.

12% for me as well.

About 200 .log files, but only nine bigger than 1 Mb.

One C: drive, nothing obviously suspect. No big files, biggest folder is Windows at 3.64 Gb. Same if I opt to view hidden files.

I get the feeling (& I really don't know what I'm talking about) that system restore has somehow been replicating or recreating, not just restoring. The restores got progressively longer, and the chunks of missing space got progressively bigger, each time.

One other thing that keeps nagging at me is that when I was struggling with the first failed SP2 install I rashly attemped to reboot from disc. What actually happened in that XP started installing again so that when I rebooted in safe mode I was offerd a choice of two XPs to work on. Doing the first system restore seemed to get rid of that, though.


  JimX 21:19 01 Sep 2004

... and yet, if I hover the mouse pointer over the C: icon, I get "Free space 3.14 Gb, Total size 55.8 Gb"


  JimX 12:15 02 Sep 2004


  Stuartli 14:13 02 Sep 2004

System Restore is enabled by default at 12 per cent.

This was set when XP was first launched in 2001 when HDD capacities were far smaller than today's offerings.

I have a 60GB HDD; System Restore is set at three per cent and takes up 1533MB.

  JimX 23:04 02 Sep 2004

Good news: the free space on my hard drive is back to normal. I deleted all restore points, but couldn't swear that the space hadn't just reappeared by itself before that.

Less good news: when I reboot, system restore tries to go back to a non-existent restore point for today despite the fact that I've turned it off. At least it only takes a few minutes about it, not nine hours.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?