system problems

  grizzley 16:29 21 Jan 2007
Locked

i have just run a diognostic on my computer and it came back with some problems for which i have attached to this message for anyone who can help.

Check COM
Verifies that objects using the Microsoft COM technology are correctly installed. Failed
COM Objects Registration Results

CLSID_CFileDisinfector - Class not registered (0x80040154)
CLSID_CFloppyDiskBootSectorDisinfector - Class not registered (0x80040154)
CLSID_CFloppyDiskBootSectorScannerStatistics - Class not registered (0x80040154)
CLSID_CFloppyDiskBootSectorScanner - Class not registered (0x80040154)
CLSID_CMBRDisinfector - Class not registered (0x80040154)
CLSID_CMBRScannerStatistics - Class not registered (0x80040154)
CLSID_CMBRScanner - Class not registered (0x80040154)
CLSID_CMemoryScanner - Class not registered (0x80040154)
CLSID_CTaskScannerSettings - Class not registered (0x80040154)
CLSID_CTaskScannerStatistics - Class not registered (0x80040154)
CLSID_CTaskScanner - Class not registered (0x80040154)
CLSID_CVersion - Class not registered (0x80040154)
CLSID_CBufferScanner - Class not registered (0x80040154)
CLSID_CVirusList - Class not registered (0x80040154)
CLSID_CLocation - Class not registered (0x80040154)
CLSID_CThreadControl - Class not registered (0x80040154)
CLSID_CExcludedItem - Class not registered (0x80040154)
CLSID_CPestRecord - Class not registered (0x80040154)
CLSID_CPestDatabase - Class not registered (0x80040154)
CLSID_CExcluder - Class not registered (0x80040154)
CLSID_CLogEntry - Class not registered (0x80040154)
CLSID_CLogger - Class not registered (0x80040154)
CLSID_CScanner - Class not registered (0x80040154)
CLSID_CQuarantinedItem - Class not registered (0x80040154)
CLSID_CQuarantineSession - Class not registered (0x80040154)
CLSID_CQuarantine - Class not registered (0x80040154)
CLSID_CExterminator - Class not registered (0x80040154)
CLSID_CVersionInfo - Class not registered (0x80040154)
CLSID_AVMenu - Class not registered (0x80040154)
CLSID_ZkAP2Sink - Class not registered (0x80040154)
CLSID_ZkFdbsDSink - Class not registered (0x80040154)
CLSID_ZkFdbsSSink - Class not registered (0x80040154)
CLSID_ZkFDSink - Class not registered (0x80040154)
CLSID_ZkMbrDSink - Class not registered (0x80040154)
CLSID_ZkMbrSSink - Class not registered (0x80040154)
CLSID_ZkTSSink - Class not registered (0x80040154)
CLSID_ZKBho - Class not registered (0x80040154)
CLSID_PopKill - Class not registered (0x80040154)

These COM objects are not correctly registered or installed.
Clicking the "Register COM" button may correct the problem.

Check BHO
Verifies that the Browser Helper Object (BHO) is correctly installed.

Getting keys from:
SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects

can anyone help to sort out. thankyou

  brundle 16:35 21 Jan 2007

Looks related to this; click here

More info on your system and what `diagnostic` you ran would be useful. Also if you are actually having any problems with the PC in the first place.

  Technotiger 16:39 21 Jan 2007

Hi, I would advise that you run a reliable Registry checker/cleaner if you are actually having problems.

  Technotiger 16:41 21 Jan 2007
  Technotiger 16:42 21 Jan 2007

ps - that is a Free one!

  grizzley 16:58 21 Jan 2007

thanks for the advice. i was using ntlnetguard diognostic utility.problems started from bootup today after installing bootskin,tweakui,iconpackager. i had to boot into safe mode and undelete these problems which did help get back to normal start.problems from earlier this week with email ongoing. i had run cclearner also cleaned out over 300mb junk.i have just ran regfix only 6 problems 1 registry,4 shortcut,1 service.

  Gongoozler 17:04 21 Jan 2007

A lot of these so called "Diagnostic" utilities cause more trouble than they are worth, and some are scams to get you to spend money to "cure" non-existent problems. So until you get the all clear from a knowledgeable member of this forum, don't click on any "cures" from this diagnostic.

  Gongoozler 17:05 21 Jan 2007
  grizzley 17:37 21 Jan 2007

thanks for advice i have scrapped ntl software some time ago but i did a reinstall of registry and some software was reinstalled i ran ntl diognostic for some reason but could not make head nor tail of report which i posted in the forum. i have avg anti-spy and anti-virus i have windows firewall with ashampoo firewall to back it up. i ran regfix to fix registry only 6 problems not bad really. ran eusing freereg cleaner and ccleaner recovered over 300mb space.

can boot into windows normally.

  grizzley 17:39 21 Jan 2007

problems seem fixed but will keep an eye on it.

thankyou to all involved and for the advice much appreciated.

  Technotiger 17:46 21 Jan 2007

Grreat, hope it stays fixed :-)

Don't forget the Green Tick.

Cheers

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?