Suspect infection

  sil_ver 23:22 08 Dec 2004

My PC running W2K recently started giving errors, such as 'explorer.exe needs to close' or winlogon.exe error clicking ok on the explorer.exe just sent it into a loop. Then there was a brief power outage whilst I was trying to load a game. This was the final straw and I decided to reformat and reinstall W2K but for some reason the format screen shows a C drive and also a D drive. As far as I can remember I never partitioned the drive (80Gb) and when I try to delete it, I get a message to say that it is W2K freespace. At one stage I noticed that the size of C changed from about 75Gb to 78Gb. I've had to use my old pc to ask this question as when I try to install anything from the web (Avast or Sygate) I get the message that the programs are corrupt. I've done chkdsk which reports all ok but trying to run sfc scannow causes it to crash. Ideally I'd like to wipe the HDD clean but it wont let me. Please help if you can. I've removed and reseated all my hardware except CPU even reset BIOS to default.

  LastChip 00:17 09 Dec 2004

PROVIDED, you have no data to save, you could try this method. But be warned, it WILL destroy ALL data on your hard drive.

Fortunately, you can access here through your old machine, so presumably, you can download onto that machine as well.

First, remove the cover of the problem machine if you don't know the manufacturer of the hard drive and note it.

Now go to the manufacturers site and download their diagnostic utility for checking the hard drive. This will fit on one or maybe two floppies. Prepare the disc's and WRITE PROTECT them.

Next, download the manufacturers utility for ZERO WRITING the drive. Prepare the disc(s) as before. This is a utility that effectively sets the drive back to condition it was in when new from the manufacturer. It simply writes zero's to the whole of the drive.

Now run the diagnostic utility (boot from it), as there's no point in going further if your dive is defective. This utility should tell you.

If all is well, run the zero write disc and let it take its course. This could take quite a long time, so do it when you have plenty of time to spare or perhaps overnight. Assuming this successfully completes, you should now be able to format the drive in the normal manner, using either fdisc or the manufacturers disc (a lot quicker!).

If you need further help, please post back.

  sil_ver 01:47 11 Dec 2004

Lastchip: Well, I did as you suggested and rewrote the drive to factory settings which got rid of the phantom partition. Formatted and loaded W2K but it got about 3/4 of the setup done and crashed to BSOD with a load of guff I didn't understand. Just two bits that said 'irq less or greater than' and the bit about 'physical memory dump'. Tried another W2K CD to see what happened and got the same result. I started to think it could be a memory problem so installed W98SE which setup and ran ok, sort of, for a while but loading drivers was a bit hit and miss until finally it wouldn't boot, That's where I'm at at present. Can only think it's either RAM or PSU problem, what do you think?.

  LastChip 22:51 11 Dec 2004

I've read about a similar problem, though I have never experienced it myself and it was due to defective memory.

If you have more than one stick, you could try taking out one at a time and see if it makes a difference, or you could try this, click here a memory tester that will run from a floppy.

Power supplies can cause really odd problems and are generally underrated in their role. Take a look in the BIOS, as most now have a section dealing with voltages and temperatures, often called PC Health. Any significant variation from the nominal value, should be considered suspect.

I have never personally known a CPU to fail (other than a fan failure causing overheating), but that's not to say one can't. However, I would view this as a "last resort". Do make sure however, all relevant fans are working correctly.

Have you added any expansion cards recently, as your IRQ message would suggest an interrupt conflict. If you have expansion cards installed (modem, network card and the like) you could temporarily remove them all except your graphics card, and try installing the operating system in a "basic" computer. This should overcome any IRQ conflicts, which can be dealt with should they arise when you add each card back one at a time.

  sil_ver 10:39 12 Dec 2004

Lastchip:.... Thanks for the reply. I suppose the IRQ fail could have been due to me not disabling the onboard sound after resetting BIOS but other errors are inexplicable. I've been looking for an excuse to upgrade my RAM to PC3200 so am off to buy a couple of sticks of 256Mb (not the cheap stuff). At present I have a single 512Mb stick of PC2700. Just for interest my mobo is an ASUS A7N8X-E Deluxe. I only bought my 400W PSU a few months ago but might buy another and keep it as a spare. Anyway I'll keep you posted.....regards

  sil_ver 22:06 12 Dec 2004

Lastchip: A new PSU didn't cure the problem but chucking out the PC2700 module and fitting 2x256Mb of DDR400 appears to have done the trick. Fingers are crossed and I've checked this post as 'resolved'. Let's hope it stays that way. Thanks for your advice, it's most appreciated.....

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017