Sun Java Problem

  ACOLYTE 15:49 10 Jan 2008
Locked

Hi Guys,

I am having big problems with Java i cant install/uninstall any version of java,i get errors applying the transforms,i have looked on the Sun Java web site and it is a known problem but as yet they don't know how to fix it ,click here

is the page that applies to my error and the workarounds they advise don't work for me either.
The funny thing is when i test my installation it shows as working but sites/apps that require Java wont work as they say its not installed.
Has anyone else had this problem and found a fix?

  sunny staines 16:05 10 Jan 2008

had the same error on install. after reboot java worked ok on a couple of sites i tested it on that needed working java installed.
i would put it down to a harmless bug as part of the install.

  ACOLYTE 16:14 10 Jan 2008

My Java appears to be working,but as it is i cannot install any updates as i get the same error,even if i try to install and start again it doesn't let me.I have tried lots of sites that require Java and its hit and miss if it works,but the most don't even see it as installed.

  sunny staines 16:26 10 Jan 2008

have you gone to control panel opening the java icon then checking the version via the "ABOUT" option.

  ACOLYTE 16:31 10 Jan 2008

I looked in the control panel other options,but the Java Icon isnt there,Java is listed in add/remove but when i try to uninstall it get the error.

  sunny staines 16:55 10 Jan 2008

have tried deleting with ccleaner.

if that fails goto windows explorer and delete the java folder then run ccleaner and a good reg cleaner. reboot and try install again but download to desktop and instal from there.

  ACOLYTE 17:07 10 Jan 2008

Yeah i tried that,its really messed up ccleaner cant run the MSI installer,and there is no Java folder where it is supposed to be in program files,i do have a folder in the application data folder,when i show hidden files but im not sure about deleting that,i have tried to run the installer from there,and from the desktop and it still has the same error,it seems like im stuck cant remove it,cant install again,cant update.

  rawprawn 17:17 10 Jan 2008

System restore and then try uninstall again?

  sunny staines 17:27 10 Jan 2008

looking like rawprawns option is the next step, remember to temp disable av software first.

  ACOLYTE 14:50 14 Jan 2008

Sorry i took so long to reply,i have tried a system restore going back in intervals as far as i could and it is still the same with all of them.
Looks like im going to have to wait untill sun find a fix.Thx guys.

  ACOLYTE 21:32 24 Jan 2008

Just a little note to say i fixed this and how.
Ok i tried everything else above with no joy so i went here click here
downloaded the cleanup tool ran it and deleted sun java install.
Then i ran ccleaner to clean the reg then reinstalled Java worked like a charm.So if any one has this error then this is how i fixed it.
Not saying it would work for you but at least its a place t start.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?