Sub-pages not loading in Firefox 2.0

  griffon 56 13:00 14 Mar 2007

Websites often require you to click a link to open a sub-page, such as dealers on Auto Trader, and sometimes Firefox opens an inset window, does a bit of business then winds up displaying a blank page whilst saying the word 'Done' in the action bar at the bottom. What add-on or plug-in do I need to ensure that Firefox always loads such pages correctly? Can anyone please help?

  johndrew 14:34 14 Mar 2007

If you are running NoScript then you may need to `Allow` the site for it to work properly. I suggest you do this on a `Temporary` basis unless you fully trust the site.

If you are running Adblock this may also affect your ability to view the page.

  griffon 56 15:37 14 Mar 2007

As far as I know johndrew I'm running nothing. I just downloaded Firefox 2.0 when prompted by Firefox 1.5 and have been using it 'out of the box' as it were. Please advise on what you have quoted.

  baldtaco 16:04 14 Mar 2007

griffon 56

johndrew is referring to the "NoScript" extension [optional extra] for Firefox. That is a very popular extension that does what it sounds like, prevents scripts from running in pages. Further, it allows you to select which pages you want to allow scripts to run on, and even the "temporary basis" johndrew mentions. Essentially, it plugs the biggest weakness of Firefox has.

He mentioned it because he, like I, suspects your problems lay with not allowing javascript. I don't know if click here was one of the places you had in mind, but the NoScript on this machine is forbidding 13 scripts to run on that page.

Anyway, that's all academic if you don't have that extension. Following the same theme though it sounds like you have javascript set defaulting to off [good]. Have a look in Tools/Options/Content tab

Supposing you do enable it, it would be better to put it back to off when you are done. [Kinda loops back round to the superior finesse of the NoScript extension johndrew expected you may have had].

  griffon 56 16:23 14 Mar 2007

Thanks baldtaco. I will check. Actually I haven't had any problems with Auto Trader, but I was looking at British Gas site and their prices page behaved in the way I described. Firefox also sometimes looks for plug-ins to satisfy a demand, seems to find one and download it and then displays the blank page again with the 'Done' word at the bottom. It's got to the stage where if this happens I give up, I can't be bothered with stuff not working as it's supposed to. I sometimes genuinely feel like putting a lump hammer through the screen - computer rage - what's that?

  griffon 56 16:28 14 Mar 2007

I've checked. I've got 'Block pop-up windows', 'Load images auto', 'Enable Javascript' and 'Enable Java' ticked under the 'Content' tab.

Do you think it could be 'Block pop-up windows' which is doing it?

  johndrew 16:39 14 Mar 2007

Looks a good candidate. Try it and see; you can always re-set it.

For your own security I would suggest you look at the Firefox Add-ons and consider NoScript and Adblock plus the Adblock Filterset G Updater at the very least. They are all free.

  griffon 56 17:30 14 Mar 2007

Funny thing. I was on Dabs site to chase up an order when it happened again. This time the site suggested I disable the pop-up blocker and when I did the sub-page loaded OK. So you are right! Eureka.

I'll download the Add-ons you recommend and pay a bit more attention to fine tuning Firefox, I've just been too lazy to do it tho' I'm paranoid about security and have all the Spyware this, that and the others loaded and active.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?