Stuck at Acquiring Network Address/SP2

  Shatter25 17:54 24 Jul 2006
Locked

I am having a problem with Internet on 1 computer at home. We recently got Cable Internet and have 3 computers wired to a Linksys router(not wireless), all 3 have Windows XP Home. 2 work great, the third keeps sticking at acquiring network address(IP 0.0.0.0), even when I disconnect it from the router and plug in the modem straight to it. I read a thread here about someone who had a similar problem, but heres what I found. After trying alot of things like a new network card, changing settings, mechanically everything is fine. So after a week of trying I re-installed Windows XP and the internet worked great. The minute I installed SP2, it went straight back to acquiring. So to test that I did a system restore to before I put SP2 on and again it worked, so again I installed SP2...back to acquiring network address. Now I found a patch on the Microsoft website for SP2 issues, tried that and no fix. I am new to having a router(we used to use a switch), maybe someone can walk me through disabling this computer from trying to acquire an IP and how to assign a manual IP, default gateway, etc correctly. I did try and do this before I did the re-install but I don't think I did it correctly because it did not work. Any help is appreciated.

  FelixTCat 18:45 24 Jul 2006

Do you have a firewall on the troublesome computer?

The firewall built into SP2 is functionally different from that previously. Try to set it to allow contact with your router's address.

Regards,

Felix

  Shatter25 18:58 24 Jul 2006

The only firewall present is the only with SP2 whichi I turned off. How do you set it to allow contact with the router?

  mgmcc 20:34 24 Jul 2006

A firewall shouldn't prevent a network adapter from getting its IP address from a DHCP server. More likely, I suspect, is an incompatibility between your particular network adapter hardware and SP2.

To assign an IP address manually, open the Network Connections folder, right click the Local Area Connection and select Properties. In the box that opens, highlight "Internet Protocol (TCP/IP)" and click the Properties button.

In the next box, click "Use the following IP address" and enter:

IP address - 192.168.1.5

Subnet Mask - 255.255.255.0

Default Gateway - 192.168.1.1 (the Router's IP address)

DNS Server address - 192.168.1.1 (the Router's IP address)

Alternatively, you can enter your ISP's DNS server addresses. If you run IPCONFIG /ALL in one of the other PCs, you will see what the DNS addresses are, because a Linksys router passes these through to its client PCs rather than allocating its own IP address as the DNS server.

If your router is allocating IP addresses in its default range, the address 192.168.1.5 should be fine and avoids addresses in the DHCP pool.

  Shatter25 13:43 25 Jul 2006

Thing is I tried 2 different adapters. The original was the onboard LAN, when the problem first started I turned that off and installed a spare Dlink Card and still got the same problem, and for both I put in the latest drivers. I agree that this seems like a hardware vs SP2 problem, my thinking is maybe something on the motherboard, would a bios update maybe help?

Last night I tried to set a manual IP, it seemed to take but I still got no connection. The router is set for 50 IP's so thats not it either. I tried alot of different things last night ranging from fixes/patches to trying different options and settings and nothing resolved it. Im actually debating on now getting her a new computer lol

  FelixTCat 15:31 25 Jul 2006

Have a look in your router's setup to see if it is restricting MAC addresses.

Every network adapter has a unique MAC address set in hardware and it is possible to set up the security on a wireless router such that it will ignore any adapter with a MAC address not on its list.

One other thing - do all your pcs have the same network workgroup name? The default is MSHOME but you can change it to anything you like.

Regards,

Felix

  Tee Dot 09:11 26 Jul 2006

Hello Shatter25.

It seems to me your router is settup for DHCP/Dynamic IP addressing. It may not work when you specify an IP on a client machine.

When a machine gets an IP 0.0.0.0, it maybe that its DHCP client service is not running. I have no idea why it would suddenly stop after installing SP2. But you may want to just make sure the DHCP is running. Here are the steps.

Click on start =>
Click on run =>
type " services.msc " in the run box (a services local window will come up)
Look for the " DHCP Client " service and double click on it.
Make sure the startup type is " Automatic " and that it is started.
Apply and close the servise Local window and see if it works.

If it works good luck. I would be happy to hear what happened.

  Shatter25 13:08 26 Jul 2006

Last night I was able to finally fix it. When I had this problem originally I tried using 2 cards, an older Dlink and the onboard LAN. Both of which gave me the same acquiring network problem. Last night I went out and bought a new Linksys ethernet card and installed it, downloaded the new drivers before I installed SP2, then when I put SP2 on it worked. My belief here is that the Dlink and onboard LAN, even though I downloaded the latest drivers were still quite old, 4-5 years and maybe thats why they never worked with SP2. Thanks for the help everyone.

  FelixTCat 13:18 26 Jul 2006

You're welcome - pleased it's fixed and you're up and running.

Please mark this thread as complete/solved in due course.

Regards,

Felix

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone