Strange problem: I think failed motherboard!

  danielgent 10:33 06 Jul 2010

Got a PC off someone to look at. Tried so much stuff but its behaivour is just WIERD!
I'm thinking the harddrive controller on the motherboard has broken in some way. Any suggestions would be much appreciated! This post is quite long so if you can't be bothered reading it just scroll to the end and tell me if the error messages indicate a failed harddisk controller. thanks!

The PC is from about 2005 I reckon if not a bit older. 2 HDDs on the primary IDE cable and 2 ODDs on the secondary. The PC one day just wouldn't boot. It gave an "unmountable boot" or something like that so was brought round my house. Didn't write the whole error down as I assumed it would be a simple problem! These error messages aren't 100% accurate as some of them I didn't fully write down and some of them flash up for so quick!
To note, an boot an error message: "primary IDE no conductor cable type 80 is installed" flashes up so quickly. might already have been there though. Tried my own IDE cable and still same error.

What i've done and found:
Can't boot from CD.
unplugged HDDs, and CDs seem to work fine (can boot ubuntu live CD).
Then when both HDDs are plugged in no CD can boot.
Linux seemed to load once with both HDDs in (though it took ages) and could see both HDDs.
booting off XP recovery CD doesn't happen when 1st HDD (master) connected. With 2nd (Slave) it boots but takes ages.

some combinations of the 2nd HDD allow the XP recovery CD to boot up (if on its own IDE cable) but not when it shares the IDE cable with the ODD. XP recovery never boots with the 1st HDD in.

So i took out the first HDD and connected it to my comp as the only HDD. Windows didn't boot and hit a BSOD (which probably is a little bit expected if switching windows to a different PC!). Ran chkdsk on this drive from XP recovery and it found errors for 1st 3 runs. Also ran maxtor seatools on it and reported no errors with the HDD.
put this HDD back in the broken comp and on booting gives a "hal.dll error". XP recovery now runs but gives an error message I've never seen before saying the CD has a file missing! (it doesn't)

So decided to try reinstalling windows. With the 1st HDD XP install wouldnt load. With the 2nd HDD XP install loads. I tried backing up 12 GB of data from this 2nd harddrive before deciding to go ahead with the installation but Ubuntu said 2 hours left so I put my own IDE HDD in instead to install windows onto that. When selecting the partition to delete and install windows on, the Windows setup gives an error message again i've I've never seen before.
"computers startup program cannot gain access...."

Maxtor diagnostic software can't see this MAxtor drive, as for HDD2 (a Hitachi). Hitachi Disk Fitness Test can see HDD2 but gives an error on trying to run.

Damaged motherboard I'm thinking? That was a long post!

Dan Gent

  daureluc 11:11 06 Jul 2010

Your post is a nit messy and difficult to understand. But from what i have read, i wouldn't think it has any thing to do with motherboard but more with one of the drive itself. Also have you checked the bios. CD wont boot if bios is not setup for it.

Ubuntu long to load, well it's quite normal if you run it from the CD.

Also boot files are located on 1 of the drive so if you try and place the wrong hard drive for boot, it just wont do it. you'll need the CD and bios setup properly so it can boot from it first.

I would suggest:
test all drive individually to find the faulty one, setup the bios to ensure it will load from the cd first even when drives are plugged in. check all drive compatibility with motherboard. Plug in 1 drive that is working fine and boot from cd to install your OS.
once all work fine, plug the other working drives

for more computer support click here

  I am Spartacus 11:13 06 Jul 2010

Have you tried different IDE cables (80 pin)?

  woodchip 11:34 06 Jul 2010

I cannot see that you have tried a new 80 wire ribbon cable for the hard drives

  danielgent 12:06 06 Jul 2010

Much thanks for the replys. Usually my posts aren't too long but this one i'd tried loads of stuff so thought I'd stuck it all down.

Daurlec - the drives are fine. The last bit of testing was done on my own Harddrive that works fine in my PC (Maxtor's diagnostic software tested OK). And the HDD from this faulty PC also tested fine in Maxtor on my PC. Its definitely this PC. I tried to write this in my messy way ;^)
BIOS is all setup fine, this isn't something that simple. I run Ubuntu from CD all the time, i mean a LONG time!
Again, this isn't as simple as me trying to boot off the secondary HDD!!!!!!

Spartacus - I tried my own brand new Asus IDE cable (one of the many I have left over from new system builds). I used this for the primary IDE cable and got the same problem but I will dig out another unused IDE cable and use this for the secondary one as well.

Thanks for the help so far,

Dan Gent

  danielgent 15:13 06 Jul 2010

to add:

I bought a new lithium battery and left the old one out for an hour. Now (with my spare HDD in) the Windows install CD boots and I can install windows! Just left it installing now and going to do a few reboots.

BUT I connected the master HDD into my testingPC using a USB caddy and it doesn't even read it...... seems like it could be a twofold problem with a faulty HDD and the BIOS needing resetting/a new battery.

I'm just going to connect this master HDD to my testingPC using an IDE cable as a slave, and see if it reads. Can't think of any reason why an IDE USB caddy wouldn't read it, when (connected by IDE) it passed Maxtor's diagostic test on my testPC. but at least it seems I might get this dodgy PC working!

  rickf 17:06 06 Jul 2010

Think its a HD issue. They are very cheap now. Try a new one and install windows OS.

  danielgent 10:29 07 Jul 2010

After getting very excited thinking I'd fixed this. The new windows installation froze!

rickf - sorry for my bad posting. this isn't my PC this is someone else computer. so when I say i'm putting MY HDD in I mean one of my spare ones thats fully tested and etc etc.

I'll only buy the PC owner (lets call him John ;^)) I'll only get John's PC a new HDD when I know thats the problem 100%. So when my HDD works perfectly in Johns PC.

cheers for the help

  danielgent 18:32 08 Jul 2010

i've actually got this PC working now. formatted it's master HDD and installed windows on it, all working fine EXCEPT
when i connect the 2nd slave HDD it doesnt boot. Gives "boot error" (or similar) whether the 2nd HDD is on the primary IDE or slave IDE cable. I think i'll just leave the 2nd HDD out, least its working now.

on another note the 2 USB ports seem to be failing and they wiped my 1TB HDD! So i've put in a USB PCI expansion card....seems to be fine now.

Thanks for all the help. If anyone does know why it doesn't boot with a 2nd HDD would be interesting to know!

Dan Gent

  woodchip 19:21 08 Jul 2010

These are things that can stop it booting if IDE jumpers have to be set correctly, Drive controller card may be faulty, the one on the drive, boot sector may be corrupt on the drive. best way is if you can get info of it in a caddy then clear the drive using killdisk click here then reset it up as if a new drive

  Dark Mantis 21:32 08 Jul 2010

A lot of it could be down to a failing PSU. It's old and the capacitors will be way under their ratings by now. Chances are it was only a cheap, low power job in the first place.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017