Strange network behaviour, Any ideas people?

  gazzaho 22:31 20 Feb 2008

I have a Packard Bell dinosaur desktop and a Toshiba Satellite notebook connected to a Linksys WRT54GS router via cable, there are also an Xbox 360 connected via cable, a Playstation 3 and Nintendo Wii connected via wireless. All worked fine until yesterday, now the two computers refuse to recognise each other and won't talk; I have no problem connecting to the internet with each machine.

Windows network set-up wizard works and completes successfully and I can save the set-up exe file to a USB stick to use on the other computer, it runs, completes, and says the network is set up but there is no SharedDocs folders for the respective computers in either network list. I can access the SharedDocs network folder on my notebook pc the one belonging to the notebook, but I can't access the SharedDocs folder on the desktop machine, it says C:\Documents and Settings\All Users\Documents is not accessible. Access is denied, so I’m beginning to suspect that the desktop is broken in some way. I use a printer to print from the notebook through the network as the printer only has a USB connection, this now won't work without the network connection.

I'm beginning to see a nuke and re-installation in the not so distant future if I can’t sort this out, something I don't want to do as I've only just done a fresh install on the desktop a month ago, and hate the thoughts of doing it again what with updates to download and all that drudgery.

Any ideas would be appreciated.

  brundle 22:43 20 Feb 2008

Is `Enable NetBIOS over TCP/IP` ticked in TCP/IP properties for both machines? Can you ping the IP address of one machine from the other? Can you access the other machine with its UNC name (\\<name>\<folder>)?

  gazzaho 23:38 20 Feb 2008

Hi brundle thanks for responding,

Both machines have the default NetBIOS settings which is use NetBIOS setting from the DHCP server. If static IP address is used or the DHCP server does not provide NetBIOS setting enable NetBIOS over TCP/IP.

I tried pinging the one machine from the other without success, ipconfig reports desktop machine IP Address as when I ping this from the notebook it lists "request timed out" 4 times then reports 100% loss. I type ping then enter am I doing it correctly? The same thing happens pinging from the other machine.

I'm not very technical so I’m not sure what you mean by access the other machine with its UNC name (\\<name>\<folder>) so I can’t try this though I’m suspecting that I can’t.

  brundle 23:49 20 Feb 2008

Yes you've used the ping command OK - no IP connectivity suggests a; enable NetBIOS over TCP/IP explicitly in your Network Connection settings b; firewall problem; c; DHCP not enabled on your router

UNC - I mean the name you've assigned to one of your other networked machines - say for example I had a network of 3 machines named Bonn, Lisbon and Perth and I shared a folder called "Data" on each. I could type \\Bonn\data at the start menu/run prompt and the Data folder on the Bonn PC should show up.

  gazzaho 00:00 21 Feb 2008

I just got ping to work, it appears when I installed F-Secure Internet Security 2008 it seems the firewall blocked the network cards! It still won't create a network connection though.

I guess it has something to do with this program though so I'm making some headway towards a resolution.

  brundle 00:04 21 Feb 2008

Can you add a `trusted network` to F-Secure's firewall config? Add your LAN address range if so.

  gazzaho 00:18 21 Feb 2008

I can't see anything to let me do that and as I said I'm not the brightest bulb in the box! I've written an email to F-Secure to see if they can help out any, it's getting late and I've been at this all day My brain is hurting LOL.

Thanks brundle for your valued input but I have to get away from this for a while and come back fresh, cheers mate!

  gazzaho 00:56 21 Feb 2008

Just to let you know brundle, I just switched on again and the damn thing is now working! I guess it just needed a while to show the connection, I can now print and access the other machines! Thanks for your input mate.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?