Stopping Background Applications whilst Gaming

  Scrivers 18:14 30 Aug 2004
Locked

When I'm playing a game that's demanding on the PC's performance, I often experience problems with the smooth flow of the game - not freezing exactly but the mouse often won't move smoothly. When playing Halo, I played it in Safe Mode to overcome the problem. I know that you can stop many of the background applications, which is almost certainly causing the problem. My computer is powerful enough (2.4GHz P4, 512Mb RAM, nVidia gForce ti4600 graphics card). Can anybody tell me what tasks I can end in "control, alt, delete" task manager and what ones I have to keep going. I'm using XP Home and there loads of them running.

  CurlyWhirly 18:25 30 Aug 2004

When I am playing games I normally disable my anti-virus, anti-spyware and firewall while NOT on the internet.
In Windows Task Manager I only leave the following ESSENTIAL system processes:

dmadmin.exe, explorer.exe, spoolsv.exe, lsass.exe, services.exe, winlogon.exe, csrss.exe, smss.exe, SYSTEM, SYSTEM idle process.
I also leave 3 or 4 entries of svchost.exe running as if you disable ANY one of these your system closes down after 60 seconds which is a similar symptom to the MS Blaster worm!
CW

  CurlyWhirly 18:35 30 Aug 2004

I normally DISABLE my anti-virus, anti-spyware scanners and my firewall while NOT on the internet for obvious reasons!


I leave the following ESSENTIAL Microsoft services running in Windows Task Manager:


dmadmin.exe, explorer.exe, spoolsv.exe, lsass.exe, services.exe, winlogon.exe, csrss.exe, smss.exe, SYSTEM and SYSTEM idle process.


There are also 3 or 4 svchost.exe entries that MUST not be disabled as if you do your PC restarts after 60 seconds which are similar symptoms of the MS Blaster worm!
CW

  CurlyWhirly 18:38 30 Aug 2004

Sorry for the double post but I thought that the first post got 'lost' due to server errors as it didn't show on your thread afterwards as I did check but when I sent the second post the first post appeared - strange!
CW

  hugh-265156 20:26 30 Aug 2004

follow the 'safe settings' listed click here to stop uneeded services from running automatically and using up ram. also see click here and consider setting up a gaming profile maybe.

check your graphics card driver is up to date and install any patches for halo etc. run a defrag also.

  hugh-265156 20:29 30 Aug 2004

ps. also try lowering the detail settings and resolution for the game and see if that helps.

  y_not 20:53 30 Aug 2004

I've always used a small freeware programme called EnditAll - stops everything Windows doesn't need to keep running.

Try a Google search for it

  Scrivers 19:55 31 Aug 2004

Thanks for your helps guys. Bazzer

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone