Still Ink Problem

  jim63 09:44 23 Apr 2006
Locked

Epson C66 and Compatible Cart. Plenty of ink in cart but keep getting message cart not recognized or change cart. Have tried SSC Utility but no use. Any other programmes I could use for printer to recognize any cart.

  Rich Pickings 10:02 23 Apr 2006

It may be that the chip on the cartridge is dead, have you tried another?

  jim63 10:07 23 Apr 2006

yes,when I install new cart it is okay. Just seems a waste of ink to throw old cart away when there is still ink in it. Epson printers always seem to give this problem.

  Rich Pickings 10:11 23 Apr 2006

It's the chance you take using compatibles I'm afraid, obviously the manufacturer's quality control is somewhat lacking. I get mine for around £1.00 each so in the scheme of things I don't mind throwing some full ones away.
Try making sure the contacts on the chip are clean, you may get lucky.

  jakimo 10:43 23 Apr 2006

"Epson printers always seem to give this problem"

its the compatibles thats your problem and not the printer

  pj123 14:37 23 Apr 2006

I normally get my compatibles for my Epson printers (895 and R200) from Choice Stationery. Not had any problems whatsoever, they also give a guarantee (which I have never had to take up).

In a silly moment I bought 10 black compatibles from 7 day shop at 99p each. Found they only get about half way through and then pack up. No amount of cleaning will get them working. I just put a new one in and dump the other one. I still have 4 left. Will be glad when I get to the end of them.

  bluto1 17:53 23 Apr 2006

Hi, I used to have an Epson C44UX and occasionally refilled my cartridges, but I needed a Zap-it to reset the cartridge chip before it was recognised again. Maybe one of the lads can tell if one is required.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone