startup problems

  chris-the-womble 20:03 10 Jun 2007

hi, just today i downloaded a program from the internet and before i installed it i did a virus scan. Avast! reported it to be clean and so i continued to install it. However after installing it i got messages from Ad-Aware which is installed on my pc saying that something was trying to change my registry so i clicked 'block'. however, this turned out to be me blocking the actual registry from opening any programs. after trying several different things i managed to get everything working again but the problems left are that when i boot up, just before the login screen comes up, i get a black screen with a box with strange characters in it. when you click ok it disappears and login continues as normal. the other problem is that only 1 or 2 things appear in the status bar next to the clock where as previously, there was about 10 things including my anti-virus software. I have tried 'MSCONFIG' and system restores but still no luck. whats worse is that i do not have the windows media centre disk as it came pre-installed on my pc so i can not overwrite windows and fix the problems. I have a vista disk but preferably dont want to use it until some time in the future. can anyone help? it will be greatly appreciated.

  skidzy 20:11 10 Jun 2007

If the program is legit,why not download it again and allow not block the changes.

If you wish to restore/recover the system to factory settings,you may have the os on a hidden partition.

Tapping F11 on startup maybe a different key, may give you this option.

What make and model pc/laptop ?

  chris-the-womble 20:16 10 Jun 2007

my pc is a Packard Bell iMedia 2470 or 2740 or something.

i have a recovery disk for the pc which will restore it to its factory settings but i do not really want to wipe my hard drive of all its documents and files.

  skidzy 20:28 10 Jun 2007

Chris what is the program in question ?

  chris-the-womble 20:38 10 Jun 2007

it was a game which i dont remember the name of as it was my brother who downloaded it and installed it (who isnt here at the moment) but it must have had something bolted onto it that added something to the registry (or something along those lines) because otherwise i would not have had an alert from ad-aware

  skidzy 20:42 10 Jun 2007

Have you tried sfc ?

Im not sure this will fix your problem as this has affected other files,but certainly worth trying.

Start/run and type
sfc /scannow (note the space /)

Understaning sfc click here

  chris-the-womble 22:52 10 Jun 2007


thanks for that skidzy. I hadn't tried that yet although since i dont have the xp disk and it requires it, the website you provided said that you could redirect it to use the x186 from your hard drive. i have a recovery disk for my laptop which has an x186 folder on it so if i use that will it work or will it make it worse?

  skidzy 23:16 10 Jun 2007

You maybe able to get the i386 off the recovery disc if explored and not booted from the disc.

If you have the os on a hidden partition,you will not need the i386 from the disc.

Best thing is to just run sfc as advised and see if it asks for the disc.

or if you like,goto:

right click My Computer/Manage/Disc management/ and look for the recovery partition if it exists and post back what is listed under drive 0

  chris-the-womble 20:16 11 Jun 2007

i have tried the sfc and it did ask for the disc at the end of the test.

also i have tried to go to My Computer/Manage/Disc management/ as you instructed but it would not let me. (this could be because i am running in safe mode at the moment)

i am currently transferring any important documents and files onto an external hard drive incase it fails to boot or something goes wrong. Unfortunately, when i tried to boot up in normal mode a few minutes ago i got a blue error screen with the 'x##########-type' error message. I will try again in a minute but if it wont boot and i have to use sfc again should i try with the i386 from the laptop disc (it is also running media centre) or should i continue transferring data onto the external drive and restore it to factory setting and wipe the drive?

  chris-the-womble 20:22 11 Jun 2007

also i checked out dllcache and i do have 636mb of files in there but is that all of it or just some of it? if it is all of it then with the i386 file from the laptop and the dll cache on the computer could i do the sfc again and tell it to work from there?

  skidzy 20:24 11 Jun 2007

Hard to say whether to wipe the drive at this stage.

Me,i would backup everything thats needed and restore to factory settings.

This i do on all my machines once a year,little bit of hassle downloading again...but i do think its worth it.

You can use any xp disc with scannow,Media Centre is xp

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

The secrets of creating gory VFX

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache