SpeedTouch ST585v6 cannot connect wirelessly

  hamo 13:10 25 Jan 2009
Locked

I recently installed at home a SpeedTouch ST585 v6 router but have only been able to connect to the internet via ethernet cable from my laptop to the router. I have been unable to connect wirelessly in order to set up a wireless network despite no end of trying.
I have a HP Pavilion running Windows Vista which I have used to connect wirelessly to other wireless networks.
Can anyone give me some advice as to the possible cause of my problem?

  spuds 17:07 25 Jan 2009

Who is your ISP, because some times they can offer good advice about certain connection problems.

I use to have a SpeedTouch 330, which gave many problems in the final stages. My ISP (Tiscali) soon resolved the problem by supplying a new wireless router.Instructions on how to set-up were also provided, and worked first time.

  oldbeefer2 10:51 26 Jan 2009

Have you dowmloaded the 585 manual, as there's lots of advice in there re connecting wirelessly?

  oldbeefer2 10:57 26 Jan 2009

Here's the link if you want it click here

  Pineman100 12:24 26 Jan 2009

Is the wireless function in your router switched on? As you're connected to the router by ethernet it should be straightforward to do this in the router's control panel.

  FreeCell 17:37 26 Jan 2009

Perhaps you could give a bit more information on how far you get with trying to connect.
Can you see the Speedtouch router in the Available Networks?
If you try and connect do you get any error messages?
What wireless security has been selected on the router?
Does it connect with security disabled but fail when security set on?
Have you checked whether any other laptop can connect to the router?

  hamo 11:05 27 Jan 2009

Hi folks. Thanks for all your suggestions, but I'm still having no luck.
Here is some more with regards to where I am at with the problem:
I live in Portugal and recently changed ISP.
I previously had a home wireless network working seamlessly with a SpeedTouch 580 router.
I went through the set-up process with disc supplied as part new ISP's wireless package. Have spoken to their on-line technical support without any success.
I have a laptop running Windows Vista and a Mac running OS X. Both these were working fine on my orignal network.
I have downloaded the 585 manual from the Thomson site.
I can see the SpeedTouch in the available networks and I have set up and named a wireless network. However, when I click on the network to connect I get a message saying that no network can be detected - both on the laptop and the Mac.
Configuration of my wireless network is via the Thomson web site and everything is set to enable the interface and broadcast the network name.
The security is set to WEP.
On the advice of the ISP's technical support I have changed the router for another 585 - with the same results.

  FreeCell 17:33 27 Jan 2009

Had a problem with a Speedtouch 580 on a Vista machine that was fixed by a firmware update. Worked fine with XP machines

Now presuming yours is new it should be up to date. Does access to the router control panel work with 192.168.1.254? If it's still using the older 10.0.0.138 then a firmware upgrade sounds required. You should be able to view the firmware version number via the Control Panel.

If you set wireless security to off, can you connect then? Isolates the problem to the security settings, rather than a broadcast problem. If it doesn't work even with security set to off then try changing the SSID on the router to something of your choice.

  hamo 18:38 27 Jan 2009

Thanks for your suggestions. However, still no luck.
Access to the router control panel is through 192.168.1.254. Software release is confirmed as 7.4.3.2. I had already tried setting the wireless security to off without success. I've now tried changing the SSID on the router - no luck there either.
I brought the laptop to a wi-fi zone and had no problem picking up the various networks available, so the problem does not seem to lie with the laptop.

  FreeCell 20:14 27 Jan 2009

Hmm! Well there are not many options here.

You've tried two different units and neither connect so chances of hardware failure of the router are small. ( Did you break a mirror recently?)

You could try deselecting Automatic Channel select on the router wireless settings and selecting one manually. ( Me thinks unlikely but easy to do to try)

If you haven't already try a Reset To Factory Defaults and see if you can connect then. (Is the router supplied by your ISP, if so they may have changed some settings)

  hamo 16:23 28 Jan 2009

Thanks, FreeCell, the change of channel sorted it. The default on the router had been set by the ISP's set up disc to Channel 1. So lucky number 7 solved the problem.
Thanks once again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?