Speedtouch 585 orange WLAN light

  Valedictor 02:33 22 Jan 2008

Hi all,

Ok, I am totally baffled by this. Am visiting my parents for the week, and when I got here, my dad told me he was having problems with getting his laptop to connect wirelessly.

The laptop has connected wirelessly perfectly before this. From what I can gather, it was working one day, then not the next.

The router is a Thompson Speedtouch 585 v6. We have the main desktop pc linked to it via ethernet cable. This all works fine. However, the WLAN light is constantly orange, and we cannot connect wirelessly.

The laptop, according to device manager and the software for the built in adapter, is an Intel PRO/Wireless 2200BG network connection.

For as long as I can remember, we have always used Windows to configure the adapter, rather than the specific software, and we have never had any trouble with this arrangement. (I seem to vaguely recall having little joy with using the specific software many moons ago when I first set up the connection for my dad).

When I open the windows configuration utility, it shows that it can pick up our wireless network perfectly. Crystal clear in fact. It say we are connected to our network. It is when we then try to open Firefox (or Internet Explorer) that we get the 'server not found' and 'problem loading page' type messages.

If I try to repair the connection, it cycles through all the stuff it is supposed to, and informs us that our connection is again fine. Still no luck with the browser pages though.

If I try and disconnect from our network and reconnect, it asks me for the WEP key, which I enter as per what is on the bottom of the router, and we are eventually back to being told we have a sucessful connection again...but still no luck loading webpages!

Now, this is what confuses me the most. If I toggle the preference to let Windows configure my wireless connection to 'off', and then open up the Intel PROSet Wireless utility, it is completely dead - everything is greyed out, and it says 'No supported wireless adapters available in the system'.

So I then check in device manager, but the Intel PRO/Wireless is right there under Network adapters, working properly and enabled.

I tried disabling and re-enabling the adapter in device manager, but this does nothing (although if I have Windows configuring things at that particular moment, it obviously instantly kills my so-called 'connection'.)

Have tried unplugging the router for a while, then powering up again, in case it was a problem with IP address (something I was told to try when I had probs with my own pc back home), but this also does nothing. Besides, the Windows utility says that the laptop adapter acquires the IP address just fine every time.

(sorry, continued in next post)

  Valedictor 02:33 22 Jan 2008

I have never been totally convinced by the integrity of the wireless connection here, even when I did get it to work before. It all seems to be a bit jumbled up somehow. It took me forever to get it set up in the first place last year, and I was never able to get the Belkin adapter in the desktop pc to work (not a problem ultimately with the ethernet cable, but still damn annoying that I couldn't figure it out). And when I eventually got the laptop to connect wirelessly, I was never totally sure if I had used WEP or WPA - there is a 10 digit WEP key on the bottom of the router, but at some point I remember it asked me to enter a longer WPA key as well!

As it stands now, when I enter the code when I go to reconnect to our network, it seems to accept the WEP just fine. But then I thought maybe it wants a WPA key instead. So I went into the wireless network setup wizard, and it gets to a screen where you can print your network settings. If I click this, it tells me that my encryption type is WEP, but it also shows my network key as being in WPA format!? So I copied and pasted the key, and used that instead of the WEP key on the bottom of the router to reconnect to my network. It accepted that too! (but still no luck with browsing).

I then tried typing in a completely made up key. It accepted that too, acquired the network address, and 'connected'! It says clearly unde the name of our network that it is a security-enabled wireless network.

Is there some kind of confusion with my encryption settings that is causing this, or is there something else I need to fiddle with to be able to view internet content again? Utterly confused. If anyone is able to help, would appreciate keeping the technical jargon as simple as poss, because, as you may have gathered, my working knowledge of this stuff is sketchy at best!

Surely if I am typing in an invalid network key, it would tell me and not allow me to connect...right?

I tried downloading the manual for the 585 to avoid having to bother you guys, but alas it was all a bit too technical for me. Sorry!

Many thanks, Jessica xx

  Valedictor 10:33 22 Jan 2008

Sorry, I forgot to mention that we have AOL running too - would the AOL software be affecting things in any way? As far as I know, the router is compatible with AOL broadband, but then I don't know if it is a router problem or an issue with the adapter?

Thanks, Jessica x

  MrSquigles 13:33 09 Feb 2008

I am having the exact same problem, the only diffence being my router has never worked, it did this the first time it was used.

Have you come up with any kind of solution, yet?

  brundle 13:46 09 Feb 2008

All that typing and no response....
The WAN light refers to the connection the ISP, even without an internet connection you still ought to be able to connect to the router itself. If you access the router's configuration pages you have connected to the router. If you check the configuration and status of the router (sorry, not familiar with Safecom kit) you will be able to see if it has detected an ADSL signal and established a connection to the ISP.

If the laptop connects to the router with a given key, changing it will prevent the whole lot working.

If you have AOL as an ISP, and your router is using your actual screenname and password to log in, you'll knock it offline when you try to login using the same details on your PC (as far as AOL is concerned you are already connected when the router logs in), you need to create a separate `router` screen-name for use only with the router.

Best to forget the wireless connection until you have established a connection with a wired one, otherwise you're chasing a moving target.

  nkafka 14:43 11 Jan 2010

Orange light, but neither of my laptops can't see the network.

When I plug straight into the router with a LAN cable the internet works fine.

My assumption is the wireless signal generator is broken. Is that a fair guess?



  Sea Urchin 14:49 11 Jan 2010

This thread is 2 years old - much better to start your own thread with appropriate title and you should get some replies.

  kdt 18:02 11 Jan 2010

I am with AOL with same router. Had problem about 2/3 months ago with the desktop connected to the router but no internet connection..think wlan red but AOL tech support asked me to get daughter in law's laptop which we connected to the router(whilst on the phone) don't remember how but the Indian techie at the other end guided me to get the connection. Everything fine since. Best thing get AOL TECH SUPPORT.I am on AOL Talk as well so did not cost anything. Good luck.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

See the Best Button Badge Designs of 2017

iPhone X review

Black Friday 2017 : date, sites participants & bonnes affaires