SpeedTouch 580 and Vista

  FreeCell 11:11 11 Jun 2007

I am trying to set up new Dell laptop for SWMBO. This is our first Vista machine and everything has gone great apart from it won't connect wirelessly to out WPA secured network. Passcode key is taken as invalid by laptop but it's exactly the same as used on XP laptops which work fine.

The router is a SpeedTouch 580 and other forums have indicated there may be a compatibility problem with Vista and the 580.

Has anyone successfully achieved a wireless connection to a WPA secured SpeedTouch580 under Vista?

  skidzy 15:55 11 Jun 2007

Not a cure Freecell,have you tried with UAC disabled.This seems to be a bit fussy at times.

I dont have the 580 so am guessing the UAC maybe the problem.

  FreeCell 16:14 11 Jun 2007

Good guess!. Can't see where/how to disable UAC on the SpeedTouch.

Have emailed both Dell and Thompson (SpeedTouch) tech support but no responses so far.

  skidzy 16:45 11 Jun 2007

Sorry ..disable UAC in Vista

Control panel/User accounts and family saftey/User accounts and turn off user account control.

This is not really advisable for most,but if you want total control over the machine this may help.

Handy link here also click here

Like ive said,i dont know if this will work im afraid.

Just out of curosity,can you set WEP on your router,even as a temporary measure.Obviously all machines codes would need to be reset.

Using Wep and Vista's firewall and the xp machines secured by there av and what ever firewall your using and not forgetting the routers firewall...should be ample security in my opinion.

Others may and probably will argue the benefits of WPA and WPK over WEP.

  skidzy 17:04 11 Jun 2007

Just a thought Freecell,have you considered opening the routers configuration and look for a firmware update ?

  skidzy 17:08 11 Jun 2007

Also click here

  FreeCell 17:18 11 Jun 2007

Well leaving aside UAC for the moment (Sorry must get familiar with Vista TLAs)

Switching to WEP 64 bit Hex and yes it does connect. So problem is WPA-Personal PSK related only.

This is the stonger security option and it's not just an issue of firewall as these stop hacking into your PC but it does allow those with knowledge and technology to crack the data stream and thus intercept your internet traffic. Don't see why a new O/S should need a degradation in level of security to make it work. Seems odd and I suspect more a SpeedTouch problem than Microsoft's. Thus the original question: ANyone got this c`ombination to work?

  skidzy 17:28 11 Jun 2007

Good luck FreeCell,at least using WEP will provide you with a form of security.
Getting hacked is a long shot in my opinion,but like you say is possible.

Have you checked the firmware,there maybe a fix within this.I did take a look around and saw plenty of the same issue you are having...hence the firmware update maybe ?

Best of luck FreeCell.

  FreeCell 13:51 12 Jun 2007

Solved.Upgraded firmware to 4.3 and removed internet protocol(tcp/ip) v6 from adaptor prpoerties and can now connect by wireless.
Internet page access seems very slow so that's next thing to investigate

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017