Speedtouch 330 USB Modem - Arrrrrrrrrgh!

  meathook 23:47 20 Oct 2006

Been trying to get onto broadband for the first time, I write this from my backup dialup connection.

Followed instructions supplied by ISP (install software first, only then plug in modem) but to no avail. I can't seem to get the thing fully installed. Many times the installation has hung my PC. If I leave the modem plugged to the USB port, Windows will neither shutdown, restart or bootup.

When I click on Speedtouch desktop icon I get: Could not create entry ("" + Speedtouch connection + "")

Even though I'm getting two solid green lights on the modem after installation "Dr Speedtouch" claims the modem isn't even connected. There is no Speedtouch entry in network connections yet in device manager the modem is listed without exclamation marks. It does claim to not have drivers installed, but then clicking on the driver details, it lists the drivers!

I'm stumped, I've tried so many things to no avail including, so far, ISPs tech support. Any ideas!


Windows XP Pro SP2, Athlon 2600+, 1GB RAM.

  woodchip 23:55 20 Oct 2006

Check this out for your USB, Go into Setup at start. Setup = BIOS Find USB Legacy and disable it, if you can find it then retry setup

  rdave13 00:19 21 Oct 2006

Suggest you unplug modem and uninstall drivers.
Run a registry cleaner, such as click here .

Reboot your pc and follow your ISP's instructions on the installation cd again.

  Stuartli 00:34 21 Oct 2006

The only suggestion I can make is that you download the latest drivers from:

click here

Otherwise it's likely to be a faulty modem as USB modems seem to be prone to faults either initially or after a period of use.

Even better, which is the route I eventually chose, is to obtain this ADSLMax/Max+2 modem router from e-Buyer:

click here (a rebadged Safecom model)

It's now down to £14.99 compared to the £17 plus VAT (and delivery charge) I paid about two months ago...:-)

It's proved a first class buy, is utterly stable and has never been switched off since the day it was installed; it's also future proof to a considerable extent.

A five port version is only a couple of pounds more or, alternatively, you could buy a wireless version if you need this feature.

  meathook 00:48 21 Oct 2006

Thanks all for the suggestions. Tried registry cleaner, uninstalling/reinstalling etc multiple times and the latest drivers from Speedtouch website.

Installed a second copy of XP alongside my usual copy, albeit on the same partition. Very first thing I tried to do was installing the modem, had all the same problems.

Had a little look in BIOS earlier but yet to try woodchips suggestion.

Hesitating to send modem back to ISP (was 'free' as part of the broadband package) as they say they'll charge an admin fee if they decide it has no hardware fault.

  rdave13 01:15 21 Oct 2006

If you removed the modem's usb connection and uninstalled, ran a reg cleaner and rebooted (important) to no avail then I would seriously consider Stuartli's advice.
On the otherhand your ISP are not delivering their part of the contract that you have signed up for. Would make it very clear to your ISP that if they do not honour their part of the contract, to get you online at BB speed, then you will go and get advice about the problem some where else.

  beeuuem 03:31 21 Oct 2006

You could try (from click here )

1. START > RUN > type "services.msc" (without quotes)

2. Search for something called "Remote Connection Manager" and make sure it is started, automatic & running.

3. Search for something called "Plug and Play" and make sure it is started, automatic & running.

4. Search for something called "Universal Plug and Play Device Host" and make sure it is started, automatic & running.

click here suggest

Q/Why do I get an error that says Cannot Create Entry?
A/You're running old system software with an obsolete version of Dial Up Networking. Head to the Microsoft site to download DUN 1.4.

  Stuartli 11:21 21 Oct 2006

meathook's system is stated as being: Windows XP Pro SP2, Athlon 2600+, 1GB RAM.

The DUN 1.4 update was back in Windows 98SE time.

  Stuartli 11:21 21 Oct 2006

meathook's system is stated as being: Windows XP Pro SP2, Athlon 2600+, 1GB RAM.

The DUN 1.4 update was back in Windows 98SE time.

  ^wave^ 12:40 21 Oct 2006

i have had problems like this it turned out to be the cd supplied by isp

  meathook 13:58 21 Oct 2006

Thanks for suggestions.

Couldn't find a USB legacy entry in BIOS woodchip.

In services, the nearest I have to remote connection manager is 'remote access connection manager' and 'remote access auto connection manager.' Both of these, along with the other suggested entries were started and set to automatic.

There are few of my services available that are not set to start automatically.

I thought maybe the supplied CD was faulty but ruled that out when the software I downloaded from speedtouch website produced the same problem.

Thanks all.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?