Speedtouch 330 Modem not recognised.

  Lord Isleworth 11:07 08 Aug 2005
Locked

Please help, friend has a new laptop running XP. Tried to connect his speedtouch modem to the laptop and phone line and doesn't want to play. The software loads and then when you plug the usb modem into the laptop it says, device not found" been through the Dr something diagnostic tool and it says there is a problem with the modem, but doesn't say the problem. I plugged the modem into my Dell 5000 and again same error message saying device not recognised. Is it safe to assume the modem is faulty or is there something I can do to configure the laptop to get it working. I previously installed the same type of modem on a desktop pc with no such problem, any help would be appreciated.
Thanks
Jon

  howard60 21:28 09 Aug 2005

same error on different machines would indicate a faulty modem to me

  Funkey 17:04 10 Aug 2005

Speedtouch modems have been known to draw more power from usb ports than the pc's can supply. However in this instance it might be a simple case that the modem is indeed faulty.

If you're running XP, and to double check if the modem is indeed faulty - uninstall the drivers, unplug the modem, reboot the pc, log into the desktop and plug the modem in without installing drivers. If the modem is being detected correctly, you should get a "Add New Hardware" wizard appear and (if your speakers are plugged in) you should also hear a DING-DING sound. This proves that a new usb device (i.e. the modem) has been recognised as being plugged in. If you dont get any indication of a new device, then its very possible the modem is faulty.

Lastly, you haven't said whether this modem has EVER worked properly, so one could also suggest that you try a newer version of the drivers from alcatel's website: click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?