Speedtouch

  Digital 19:37 31 Jan 2005
Locked

Since loading the software that came with my SpeedTouch modem (for Virgin Net) my previuosly very stable W98SE has become unstable, the PC freezing & having to be restarted or the dreaded blue screen appearing. Has anyone else had a problem like this?

  Fruit Bat /\0/\ 19:42 31 Jan 2005

Problem occurs if modem plugged in before loading software.

Unplug modem

uninstall software

re install drivers and software from disk

plug in modem

  Digital 20:04 31 Jan 2005

Thanks Fruitbat but I already did that. I have e-mailed Speedtouch support but they don't reply.

  Lionheart ? 20:12 31 Jan 2005

May be of help click here

  Digital 20:48 31 Jan 2005

Thanks Lionheart, good idea but I do have the latest drivers.

  Furthark 19:16 15 Feb 2005

I had the same problem it was due to an old version of NAV upgraded and everything ok (except for trying to run a scanner & speedtouch off the same USB port)

  Digital 11:27 16 Feb 2005

Thanks Furthark but I use AVG & it's up to date.

  pimpers 13:55 16 Feb 2005

I had the same trouble but I did not get any sensible answer from Speedtouch.
I had a process of removing first, Zone Alarm as I know that this had been a problem with other programes in the past. Next Nortons, this was a vast hogger of resources. I then tried again unloading the drivers and re-loading them and things seem to work better. Once stable I then loaded the others back on and it was O.K.

I had the same trouble again when I upgraded to ME. In the end I gave up and bought a new PC running XP.

Can your PC run with XP?

Hope this helps.

Pimpers.

  Kate B 14:11 16 Feb 2005

I haven't used a USB modem myself but I keep seeing warnings to the effect that they're flaky and recommendations to swop them for an ethernet modem and/or router. Might be worth considering if the usual tricks haven't solved the problems. Certainly I've never had any problems using an ethernet modem/router.

  Digital 14:27 16 Feb 2005

Thanks Pimpers, Kate B & everyone else. I just discovered that I couldn't access my Delkin Reader-15 (USB MMC reader). Trying to re-install it kept freezing the PC, several times! Being of a suspicious nature I uninstalled the SpeedTouch modem, then successfully re-installed the Delkin Reader & it worked OK. Then I re-installed the SpeedTouch modem & both it & the reader work OK. Only time will tell if all is cured! I must agree about SpeedTouch helpdesk's help, it isn't always as helpful as one might hope.

  Digital 17:25 16 Feb 2005

Re SpeedTouch helpdesk, got some advice from them, followed it & had to re-install W98SE! 'Nuff said!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?