Sony Vaio VGN-FS215S CDDVD RW fault

  4chihuahuas 23:20 14 Oct 2007
Locked

Sony Vaio VGN-FS215S CDDVD RW fault
Hi wonder if anyone can help.
Have a Sony Laptop as above with a internal Sony DW-D56A CDDVDRW - The laptop recognises it and device manager says its working but it is not at all - the only thing it does is spins(when a cd is in) and ejects(when prompted)
Have tried uninstalling and reinstalling without success and actually taking it out and putting back in.
Have also tried to replace with an identical drive and also the updated DW-Q58A - whenever i put in a new drive and try to boot up the laptop i get a black screen and the message - operating system not found.
The laptop will then not work at all - it will only work without the drive or with the supposed faulty drive installed or disabled - it will not work at all with a new drive and i've tried 3!! - the new drives do work as have passed them on to other people but am not sure if the original will work in another laptop.
Think there must be something wrong with the laptop - has anyone got any ideas?
thanks in advance
Chi

  €dstowe 07:16 15 Oct 2007

The problem with laptops is that they are so compact it is almost impossible to do any physical repairs to them without very specialised tools and equipment. If the machine is still under warranty then take it for repair at a Sony specialist. If not, consider how much you would be prepared to pay for repair and take it from there or, buy an external USB drive and use that. An external drive will most likely be almost as large as the computer but it will get you out of a fix without too much expenditure (probably cheaper than a repair).

  ambra4 06:12 21 Oct 2007

This might work to get your drives working download and run

click here

  4chihuahuas 14:39 22 Oct 2007

Hi again
thanks for both replies - tried the drive fix without any success but thanks for the tip

i have been using an external drive but its such a hassle with a laptop and would love to sort this problem.

Have tried yet another replacement drive with the same result..... just get the error operating system not found but as soon as the new drive is disconnected the laptop boots up o.k so its not a hard drive prob
Have also tried finally connecting the drive once the laptop has booted up and it just completely freezes
can only get the laptop to work without a drive or with the faulty one connected - anyone got any other ideas its such a pain!!
thanks for your help
CHI

  ambra4 14:53 22 Oct 2007

Have you try this site it might help

click here

  4chihuahuas 15:17 22 Oct 2007

Hi thanks for your quick reply and helpful link
have checked all my downloaded drivers as per the Vaio site and everything seems up to date as it should be - have also gone thru device manager and it says that the device is working properly???

any more top tips?
thanks again CHI

  ambra4 15:45 22 Oct 2007

Have you try updating the drive firmware

  Fruit Bat /\0/\ 16:02 22 Oct 2007

have also gone thru device manager and it says that the device is working properly??

device manager is not always reliable , it is better to uninstall the device , reboot the computer and let windows reinstall it.

  4chihuahuas 16:25 22 Oct 2007

Hi guys

have tried updating the firmware and i have the most up to date version already installed....

have also uninstalled and reinstalled the drive as you describe......

still not sorted :(

  wildrover 13:42 14 Jun 2008

Had a problem with my combo drive. Searched the helproom and ambra4's first 'click here' fixed it. Brilliant! Have been struggling with this for some time!!

Cheers

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?