Software (eg nero) isntalling to wrong drive...

  irishsteve 16:47 29 Mar 2007
Locked

Not as simple as this sounds - normally you can just select which drive to install software to. However, some programs are trying to auto install (and not giving an option to change) to E:/ which doesn't exist, unless I turn on my ext hard drive, which doesnt have an op system on it. I need these programs to default to installing on C:/ and I can't work out how to do it. Help!

  ArrGee 16:55 29 Mar 2007

Once your external is unplugged, go into the device manager and see if you can locate an entry for E:/. If it's there, remove the entry and try a re-install.

  irishsteve 16:56 29 Mar 2007

Already tried that mate. This actually happens when the ext drive is unplugged and turned off.

  ArrGee 17:24 29 Mar 2007

With some hardware, even unplugging it or turning it off doesn't remove the entry from the device manager.

But as you have tried that, give this a go:

Start - Run - Regedit

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

On the right panel there should be a string called ProgramFilesDir which you can modify to run on C instead of your external E.

  irishsteve 18:04 29 Mar 2007

it says its pointing to C:/Program Files but when I tried to install Nero again, its still looking for E:/. Confusing.....

  ArrGee 21:52 29 Mar 2007

Let's try this with Nero first.

First of all, go to the Control Panel and Add/Remove programs to make sure there is no entry for Nero.

Then go to your Start - Programs menu to be sure there are no Nero entries there.

Clean out the registry first (with great care) with CCleaner. Just delete the entries that appear with any entries allocated to Nero, and nothing else. See how that goes first:

click here

After that, run this to give you a safe registry cleanup:

click here

Run the above again.

Then restart and try installation again.

  phono 22:04 29 Mar 2007

This any help? click here Nero's own cleanup tools for system files and registry "For a clean reinstall of our software".

  irishsteve 22:08 29 Mar 2007

I solved the problem. I turned on the ext drive, tried reinstalling nero, so there was a drive E:/. managed to get into the custom installation options, and select drive C for it to install to. so its pretty much fixed.

thanks for the help though!

  irishsteve 22:09 29 Mar 2007

resolved

  phono 22:21 29 Mar 2007

Good stuff, glad to hear all is well again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017