Socket error 10107, help please!

  gazmix 20:20 01 May 2011


Ok, i know i posted about hibernate not working & i will go there in a bit!

My pc was running ok until my usb mouse malfunctioned & everything froze! I can't get online with broadband or dial-up on my usual pc at all!

When i try to retrieve my mail i get 'socket error 10107'

I had to uninstall my firewall & i think it's left some remnants & corrupted my pc! I've tried system restore & nothing! When i reboot, i get 'firewall.exe' has encountered a problem & must close & i get chance to send or don't send report to microsoft!

If i say 'don't send', my computer makes noises & one of the green lights on the front goes really fast, not the power light! I can't go online or receive mail at all even though my router is ok!

Can anyone help me with this as its a real nightmare!

  Ian in Northampton 20:53 01 May 2011

This might help:

  gazmix 00:05 02 May 2011

I tried this & nothing, how about wisefixer, anyone heard about this!?

  birdface 00:42 02 May 2011

Maybe give your security programs a run and see if they find any problems. Hitman pro is quite good at finding things that others cant. This from Bleeping text

  rdave13 00:59 02 May 2011

If the above doesn't help try booting to safe mode. Tap the F8 (or in some PCs the F5) key to get to the Advanced options page. Here you will get to the options of how to boot. Try 'Last Known Good Configuration' first. If that fails then boot to safe mode again and try system restore to before you had the problems. Note once you restore in safe mode then your later restore points will be lost.

  gazmix 16:12 02 May 2011

I haven't done system restore in safe mode yet, but have done msconfig in safemode & deleted the firewall at start, but that did nothing! All my progs seem to be none responsive! I think i've fried my registry!

I have ERUNT reg backup dated back to early 2010 & ran that after this issue started! I guess thats why all my programmes have frozen as some may not work after all microsoft updates as the reg will hace changed! A friend told me this, is it true! As my programmes are non responsive!

Could i write over the corrupt progs by reinstalling them? or do i need a complete xp install.

  gazmix 16:14 02 May 2011

I have also googled & there is s specific prog called WiseFixer to sort this! Is this true?

  gazmix 17:46 02 May 2011

It seems i have sorted it!

I downloaded the firewall.exe file & ran it & it overwrote the obviously corrupt firewall programme!

I think what i did initially was uninstall the firewall as i though i had to because it wasn't accepting the licence key & it wouldn't uninstall & caused this socket problem! I then did an Erunt backup thinking it would sort the prob! Thing is, the backup was made early 2010! Obvioulsly after many microsoft updates, the registry would've changed & things went belly up!

I'm not sure why though that overwriting the firewall worked as i still had set the registry back to 2010.

Is it important to back up registry after every microsoft update & do i need a firewall at all?, isn't windows firewall sufficient? & also the one in my router! ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?