Slow running USB

  bigrad 05:24 10 Nov 2010
Locked

I am running XP sp3 and I have recently noticed that my USB sockets are now running at 1.1 instead of 2.0 - I have checked device manager to confirm this and tried to update drivers using the instal disk but every response says driver is up to date. I have checked other posts here but cant find a solution that works. They were working fine a few days ago. Is there a simple answer? What checks should I work through to get these back to optimum 2.0? Many thanks.

  KremmenUK 06:58 10 Nov 2010

I think Microsoft released USB2 drivers after the initial release of XP.

If you have an original XP disk pre any service packs you may need to download the specific M$ update for USB2.

If these are the Mobo USB ports then you may need to also seek out some recent Mobo drivers.

  bigrad 07:27 10 Nov 2010

Thanks. What I don't get is that these USBs were running fine at 2.0 a couple of weeks ago and now they're not. Nothings changed since then but now they're running at 1.0 - How does that happen? Is there a simple solution? I have already tried searching the original XP disk. Cheers.

  Les28 08:27 10 Nov 2010

No Enhanced usb showing in device manager?
You say you've had a look at other posts here about this problem, have you checked in the pc's BIOS maybe the advanced tab there to see that High Speed USB is enabled?

Your onboard cmos battery is OK? Clock keeping the correct time and date?

  bigrad 08:44 10 Nov 2010

CMOS batt OK. Device manager shows standard open USB host controller - now. But before I am sure it was showing an enhanced usb, although I must admit I dont check it that often. I only spotted a problem with the speed when my back up started taking hours rather than minutes. It was fine last month. It was working at high speed before and now its not - so a mystery. I havent fiddled with BIOS as I seldom if ever tinker with it due to a bad past experience, but I could have a look when my back up finishes. I have checked my XP instal disk for drivers with no joy but would it be an idea to delete all the usbs in device manager and then reboot and let Windows reinstall? I am running SP3 already, but I dont want to screw up the usbs altogether by trying something doomed.

  cocteau48 10:06 10 Nov 2010

This maybe worth a try:

Open command prompt and copy and paste this line:

set devmgr_show_nonpresent_devices=1

enter

followed by:

start devmgmt.msc

and enter again,

This will open the device manager and show all entries including the ghost entries (they will be slightly greyed out) of all previously connected USB devices.

Unplug all USB devices and uninstall everything under the USB heading in device manager.
You may require a PS2 mouse plugged in because if you are using a USB mouse you will lose that as well.

Reboot and start plugging in your USB devices one by one.

Windows will re-establish and install each device as you plug it in.

See if that helps.

  bigrad 10:19 10 Nov 2010

Thanks guys - I have a couple of things to try here. I'll give them a go and post the outcome.

  cocteau48 10:20 10 Nov 2010

Just another thought:

If it is the same device in all USB sockets which is showing the wrong speed then it may well be a problem with the actual device itself.

I struggled with this issue for a long time with a Freecom ext HD and it was only when i plugged it into my laptop and it still showed as running as a 1.1 device that I twigged that the problem was with the ext HD itself.
A new ext HD solved the problem.

  bigrad 10:38 10 Nov 2010

I have two Ext HD in two sep USBs and they are both now running slow. I have swapped one of them over to laptop and it runs fine. This issue will get fixed in the end no doubt but its a real pain.....!

  Fruit Bat /\0/\ 17:09 10 Nov 2010

You need to have the "Enhanced driver" showing in device manager.

Uninstall all USB devices and reinstall and download an enhanced driver for your USB chipset i.e. Nec / Via etc.

  bigrad 08:53 11 Nov 2010

Ok. Some progress. BIOS checks out ok. uninstalled and reinstalled all devices, rebooted and then connected each device one by one. All detected OK. Transfer speeds now much better but still slower than previously. Is it possible to measure transfer speeds? - I've never actually tried to before...Also on reboot windows reported that a device connected to a USB hub was running at 1.1, but when I checked it appeared that some of the ports on the 2.0 hub were actually operating at 1.1. whilst others were still at 2.0. I didnt think that was possible, could it be some ports on the hub have a discrete fault?

Device manager now looks like this:

Standard Enhanced PCI to USB Host Controller
Standard open HCD USB host controller
UNKNOWN DEVICE (x5)
USB Mass storage device
USB Root Hub
USB Root Hub

So I'm happier now but not completely resolved on the transfer speed issue despite now having an apparently healthier device manager setting for USB. Plus possible fault on USB hub. Any further comments welcomed. Cheers.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?