Slow drive on usb2 10mins per Gb

  enonod 11:06 24 Jan 2009

I believe my USB 2 is slow with an external hard drive (two different). It takes 10 minutes to transfer 1Gbyte.
Using Fujitsu Siemens Amilo pa1510 with XP Pro sp2

System Info as below...
The drive was originally Fat32(LBA) and did not allow more than ~4Gb files. I reformatted to NTFS.
The Windows driver for USB is 01-07-2001 5.1.2600.2180
for storage device it is 5.1.2600.0

Tried optimising for performance, no change.
Any advice please.

IRQ 0 System timer OK
IRQ 1 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard OK
IRQ 8 System CMOS/real time clock OK
IRQ 12 PS/2 Compatible Mouse OK
IRQ 13 Numeric data processor OK
IRQ 14 Primary IDE Channel OK
IRQ 16 Microsoft UAA Bus Driver for High Definition Audio OK
IRQ 17 ATI Radeon Xpress 1100 OK
IRQ 19 Standard OpenHCD USB Host Controller OK
IRQ 19 Standard OpenHCD USB Host Controller OK
IRQ 19 Standard Enhanced PCI to USB Host Controller OK
IRQ 20 OHCI Compliant IEEE 1394 Host Controller OK
IRQ 20 O2Micro Integrated MMC/SD Controller OK
IRQ 20 O2Micro Integrated MS/MSPRO Controller OK
IRQ 21 Microsoft ACPI-Compliant System OK
IRQ 22 Standard Dual Channel PCI IDE Controller OK
IRQ 23 Atheros AR5005G Wireless Network Adapter OK

Belkin Bluetooth 2.0 USB Adapter USB\VID_050D&PID_0012\6&17E92DA4&0&7
Canon MP110 USB\VID_04A9&PID_1700&MI_00\7&1FC32747&0&0000
Canon MP110 Series Printer USBPRINT\CANONMP110\8&DDDD6AB&0&USB001
Generic USB Hub USB\VID_050D&PID_0237\5&1D432CA4&0&8
HID-compliant mouse HID\VID_047D&PID_106E\7&2262F007&0&0000
Standard Enhanced PCI to USB Host Controller PCI\VEN_1002&DEV_4373&SUBSYS_10B81734&REV_80\3&13C0B0C5&0&9A
Standard OpenHCD USB Host Controller PCI\VEN_1002&DEV_4374&SUBSYS_10B81734&REV_80\3&13C0B0C5&0&98
Standard OpenHCD USB Host Controller PCI\VEN_1002&DEV_4375&SUBSYS_10B81734&REV_80\3&13C0B0C5&0&99
USB Composite Device USB\VID_04A9&PID_1700\85LI5W
USB Human Interface Device USB\VID_047D&PID_106E\6&17E92DA4&0&4
USB Mass Storage Device USB\VID_18A5&PID_0216\160500052358
USB Printing Support USB\VID_04A9&PID_1700&MI_01\7&1FC32747&0&0001
USB Root Hub USB\ROOT_HUB\4&47A0F18&0
USB Root Hub USB\ROOT_HUB\4&2AA590AC&0
WDC WD64 00AAVS-00G9B0 USB Device USBSTOR\DISK&VEN_WDC_WD64&PROD_00AAVS-00G9B0&REV_\160500052358&0

  woodchip 11:59 24 Jan 2009

Its got to be running as USB1.1 not 2 at that speed

  woodchip 12:01 24 Jan 2009

Its got to be running as USB1.1 not 2 at that speed

Check Device Manager under USB and look to see if you have a Enhanced Host Controller loaded if not its only USB1.1

  enonod 12:23 24 Jan 2009

Thanks for the reply. Yes I do have enhanced in the list and the drive is connected to the root hub below it. There is no facility in BIOS to change anything.
The driver date from Windows seems old.

  enonod 13:59 24 Jan 2009

Please can anybody help, I am waiting to clear a lot of data to backup and it will take hours at this rate of 1.1
All three ports on the computer are the same.

  Fruit Bat /\0/\ 15:54 24 Jan 2009

Uninstall and reinstall The USB chipset drivers.

  enonod 16:18 24 Jan 2009

Thank you Fruit Bat.
I uninstalled the standard enhanced pci to usb and then it re-installed when I restarted, is this what you mean or do you mean the AMD processor driver?
The only 'chipset' driver in the set is the VGA chipset.

I have o2Micro 4in1
Processor with Powernow (Turion 64)
VGA Chipset
Motorola SM56 modem
Realtek ALC861
RTL8139 ethernet
WN6301A minicard WLAN IEEE802
That is the complete set and there are no BIOS settings available.

  Fruit Bat /\0/\ 16:28 24 Jan 2009

Just the USB drivers

Has it solved the problem of slow copying?

  enonod 16:30 24 Jan 2009

No everything reinstalled but still the same. The only driver seems to be the one referred to in the first post, I have nothing specific to USB.
I have two drives, both acting the same.
I have tried all three USB 2 sockets, all the same.

  Fruit Bat /\0/\ 16:37 24 Jan 2009

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  MAJ 16:42 24 Jan 2009

It might be worth your while to invest in a PCI to USB2 here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?