Site works on any computer but mine!

  Gaz W 23:17 18 Oct 2004

I bought a domain name at 1and1 and web hosting at last week, and have been able to change the DNS servers on the 1and1 domain to point to my hosting, which works as long as I'm not using my computer/internet connection!

Prior to purchasing the hosting I made it redirect to my old site, and this is what is still happening when I access it at home. I have asked various people to check it out for me, and it seems that the problem is with either my computer(s) or maybe Telewest.

What should appear at the moment is a page with some text on it saying something like "it's finally working" - but I can't remember what I typed exactly - something stupid along those lines!

What I get is my old site with a logo & layout (just to test CSS and server side includes with, not really a site at all). I have tried deleting my temporary internet files, etc, but that hasn't helped. Maybe it's something to do with DNS and Telewest? Without knowing how DNS works exactly I can't explain what I mean though!

Anyway, I would appreciate it if anyone could offer an explanation.

Thanks in advance,


  Sir Radfordin 00:29 19 Oct 2004

There is a chance, though I'm told they don't, that Telewest are using their own caching system of pages. Or it could be that they have their own DNS which is out of sync or causing problems.

Do you know the IP address that your domain name resolves to? If so put it into your hosts file and see if that solves the problem for you.

Apparently a DNS record has a TTL value (Time to Live) which can be set to something short or something long (funny that!) If it is set to 1 week (or greater) than it may take a while for that change to be fully reflected. Ideally if you are going to make frequent changes to DNS records you want a low TTL value.

A good old Ctrl+F5 can work wonders even when you have deleted temp files and have set your browser up to check for a newer version of a page every time you visit a site.

  Gaz W 01:02 19 Oct 2004

Thanks for that info... I was wondering whether it was something along those lines, to do with Telewest, and I think you've confirmed it. If the problem doesn't clear up tomorrow I can ring them and use some of the proper technical terms you mentioned!

I've tried all the basic stuff; Ctrl + F5, deleting all temp. files (but it happens on any computer on my network).

I've even tried getting it to check for newer versions of pages on every visit, and still I'm getting the old 1&1 redirect frame!

It would have to be Telewest that's dodgy!

Anyway thanks for your help - I'll let you know what happens tomorrow!

  Gaz W 01:05 19 Oct 2004

The internet connection does seem to have been a bit slow today, so maybe that's got something to do with it.

When I ping or I get "request timed out".

  Sir Radfordin 09:24 19 Oct 2004

Don't read too much into the lack of respone on the ping it could be that Telewest have disable Ping on their systems so you wouldn't get a response. You could try doing a tracert to the address.

  Gaz W 15:07 19 Oct 2004

I still get request timed out after a few hops. Also the problem is still there!

I think I'll ring them now.

  Forum Editor 15:53 19 Oct 2004

that says "Finally it's working properly - come back in a week or 2"

Is that your page?

  Gaz W 16:29 19 Oct 2004

Hi FE, yes that is what should appear. However, what I'm getting is the old redirector for 1&1 to my old free hosting site.

I have just been informed that the problem could be with my own Windows 2000 server and DNS, as I use Internet Connection Sharing, so I'm going to give that a try.

How can I make it update quicker if that is the case?

  Sir Radfordin 17:03 19 Oct 2004

What URL are we working off here?

Unless you have done something then I doubt you have your Win2k box acting as a DNS. If you are using ICS then it will use the hosts file off the 'master' computer (or the proxy) and not the client PC.

Have a look at what IP address you have as the DNS for your client PC. If it is then it is using the ICS Master computer. The ICS master computer should have a DNS record (2 hopefully) for your Internet connection and should not have one (unless you need it for something else) for its LAN connection.

  Gaz W 17:15 19 Oct 2004

OK here's what I did...

1. Went on my Windows 2000 server, went to a command prompt and typed "ipconfig /flushdns"

2. Tested out click here in my web browser and it redirected to my old free hosting.

3. Tried click here and it redirected, then straight away changed over to the "proper" page that you all see. Clicking refresh or reloading it completely brought up this page.

4. At this stage I went back to my command prompt and did tracert - it traced back to, which is correct. I also did tracert click here, and that traced back to, which is 1&1 Internet.

5. I tried flushdns again in command prompt, and tested the sites again, but now it's back to square 1; both trace back to and redirects it to my free hosting!

It could still be my server, so I might try restarting it but I would be grateful for any more suggestions first, since it takes ages to restart!

  Gaz W 17:17 19 Oct 2004

It's made my URLs into links! If you hover the mouse over them you should see what they are supposed to be though!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017