SiS 7012 driver unnobtainable for Audio Device

  justkevin 13:02 25 Mar 2007

As my speaker has dissappeared from the task bar I am trying to update the driver with no success,unless I become a member and pay a fee etc.I have read a number of posts that say this is a known nightmare and the solution is to buy a sound card.Is this good advice and how do I uninstall the onboard sound device,I have a Gigabyte motherboard that I imagine contains the components that make the sound work.

  AndySD 13:23 25 Mar 2007

Have you tried the GIGABYTE dOWNLOAD cENTER click here

  Fruit Bat /\0/\ 13:39 25 Mar 2007
  skidzy 13:43 25 Mar 2007

And..... do you have the motherboard drivers and utilities disc,this should reinstall the drivers for onboard sound.

  justkevin 00:23 26 Mar 2007

I have found the disc with the drivers and motherboard utilities but don't know the procedure.I tried to open the driver folder and was asked ..what program did I want to open it with...didn't know also the three drivers that were in the folder had a different number to the one I am looking for,though the label on the disk gives a correct description.If I remove the driver via device manager and insert the cd ,will the driver find itself the place for it to go or do I have to stipulate the path? Just not sure how to proceed.

  skidzy 15:57 26 Mar 2007

The disc should just run from the cd drive,if not goto My Computer and double click the cd drive and open,then install the audio driver.

If the drive is not autorunning,try a repair click here

  justkevin 16:39 26 Mar 2007

The gigabyte cd has found the file and loaded it but when it comes to the driver installation it doesn't recognise the file as being anywhere ,it asks for a completely different named file and asks to insert WMD c D not sure what that is but it isn't the windows installation file because that isn't recognised either.I tried another driver Realtec AC'97 Audio and that is shown to be working properly according to Device Manager but there is still no speaker symbol or sound at all.It seems that the file exists by doing a search but when I get to driver installation the file is not recognised

  skidzy 16:43 26 Mar 2007

Ok,lets try the codec pack,maybe the system has missing or broken audio codecs click here

Also check within Control panel (audio settings)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017