Simple (!) networking query

  mikeyb59 14:05 05 Jan 2004
Locked

Simple!! may be the wrong word.

I have recently bought a new laptop which operates fine on my wireless network. By this, I mean it can access the internet and "see" files on my desktop. My problem is, I can share files etc using my laptop but my desktop will not "see" the laptop.

Desktop uses XP Pro & laptop uses XP Home.

Have removed all firewalls (XP & Sygate - relying on my router to protect me), but nothing I do can change this.

OK, It's not a major problem as I can perform all tasks from the laptop, but its a bit of a mystery why its so one way!

Hope someone can shed some light on this.

TIA Mike

  scotty 14:48 05 Jan 2004

One possible cause would be if you have not set-up at least one directory on the laptop's drive as a shared directory.

  A15 15:18 05 Jan 2004

I do not know if this will work in XP but......

When I tried to network 3x 2000 pro machines together, I found that each machine had to use the same login password or I had exactly the same problem. User name did not matter, but workgroup, protocols & passwords had to be identical or no go!

Like I say XP may not be the same, but it must be worth a try!

  spikeychris 15:32 05 Jan 2004

Couple of suggestions...

1. Enable the Guest account on Pro

2. Use Simple File Sharing


3. Make sure sharing is enabled


4. Make sure that NetBIOS over TCP/IP is enabled on all computers.



P2P networks use NetBIOS for File and Printer Sharing. NetBIOS identifies computers on the network, it also locates computers and shared disks and folders on the network and allows them to appear in My Network Places


To enable NetBIOS Over TCP/IP

Open the Network Connections folder.
Right click the local area network connection and click Properties.


Double click Internet Protocol (TCP/IP).


Click Advanced.


Click WINS.


Click the Enable NetBIOS Over TCP/IP button.

  mikeyb59 16:00 05 Jan 2004

scotty

All drives are shared - still no go.

spikeychris

Have followed all your suggestions with no joy. Administrator accounts are enabled on both machines. Will try your suggestion re Guest account.

As I said its not the end of the world as I can perform all functions from the laptop, Its just a bit of a mystery that the laptop can see all, while the desktop can see none.

Keep the ideas coming!

  spikeychris 16:06 05 Jan 2004

Simple file sharing, the only method on Windows XP Home and one of two choices on Windows XP Professional, always uses the Guest account. (Classic file sharing also automatically uses the Guest account if the original logon request fails.) If access through the Guest account is inhibited, then sharing cannot work, except when logging on to XP Professional with classic file sharing through another account.

  mikeyb59 16:27 05 Jan 2004

Thanks for that. Do you mean I should create a guest account in XP Pro?

At the moment both pc's are set up with admin accounts only.

  spikeychris 16:41 05 Jan 2004

Go to run and type this

net user guest /active:yes

This will enable the guest account.

  mikeyb59 16:56 05 Jan 2004

Tried that and still get a blank screen on XP Pro.

No big deal as can do everything from my laptop.

Still strange tho'.

  spikeychris 17:00 05 Jan 2004

Sorry, disable Simple File Sharing first in XP Pro then type the above.

  mikeyb59 17:12 05 Jan 2004

spikeychris

Will try this later as have to go out now.

Watch this space!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

There’s more to Finnish artist Tove Jansson than creating the Moomins

iPhone X news: Release date, price, new features & specs

Comment regarder la Coupe du monde de rugby à XIII en direct ?