Shift + double click bypasses ms access start-up

  futurist 19:58 09 Oct 2008
Locked

hi, i have the worse problem you can have with access. i have a database that has a user log-in form. the problem is that you can bypass this security be holding down control while opening the database. i have read about the same problem but none of the solutions have worked. any help would be greatly appreciated. (By the way. it uses linked tables so the shift option does not need to be re-enabled to edit the database

  Chris the Ancient 09:24 10 Oct 2008

You have me puzzled!

How/why did you create this password system using a user form?

Access (after Access 2) has a powerful password protection system as part of it's application. The preferred methodology is to use this.

I suggest that you do away with your user form system and use the in-built security facility. This is available in the Tools menu as... Security. The help menu gives a reasonable guide as to how to use it.

  futurist 17:51 10 Oct 2008

i can't do that. users need to be able to create new users to give staff/visitors access to the database and it logs the activities of users who log on, so it needs to know their user id

  futurist 15:59 11 Oct 2008

Even if you do set a database password, it you hold down shift as you click ok, it will just display the db window. i do not want users to be able to directly access the tables, only through forms, but thanks for your reply. any other ideas?

  Chris the Ancient 12:44 12 Oct 2008

Sorry for the delay, been out quite a bit.

Try...

Tools/Startup and untick Use Access special keys and make sure Display Database Window is still unticked.

If you get really stuck, I did obtain a small, separate Access program which allows the database 'owner' to enable/disable bypasses - but I can't find it again in Google. You can PM me is you wish, and I will email you a copy to play with as soon as I'm back at the computer.

However, I still think that a userform is less clever than using the proper password system.

CtA

  futurist 19:14 21 Oct 2008

allready tried the disable special keys, first thing i did. i have found that this problem is limited to windows vista and office 07 gets round it. any other ideas, and what is this seperate program?

  futurist 20:05 28 Nov 2008

any more ideas?

  Sea Urchin 21:32 28 Nov 2008

Did you take up Chris the Ancient's offer to send you the separate program he has?

  Chris the Ancient 11:25 29 Nov 2008

Did a quick Google search for "Bypass Access keys" and there are some ideas there.

My offer of the freeware program I found a while back is still open! However, I do know it works in XP; but I've not got Vista to try it with. Click on the yellow envelope next to my handle, email me and I'll happily send you a copy.

CtA

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?