sfc /scannow

  Greengage 10:33 08 May 2007

Having a problem running SiSoft and keep getting message "could not initialise database - check database files etc..". Decided to run sfc /scannow with my Windows XP Home SP2 disk inserted and after it starts I receive message "files that are required for Windows to run properly must be copied to the dll cache - insert your Windows XP Home Edition SP2 disk" which is already inserted. I then get message "CD you provided is the wrong CD etc" but it is the correct one. I have two PCs and one laptop all running XP Home SP2 and each has its own genuine disk. I have tried inserting the other disks but still get the same message. I have also copied the i386 folder from the CD to my C drive and amended the source path in the registry to point to this but when I re-try, I still get the same message and hence cannot run sfc /scannow. My optical drive is working properly.

I seem to recall that I had this problem once before and overcame it but running a repair installation of XP Home but I do not want to go through this procedure again with the subsequent need to download all the Windows Up-dates. I would be grateful for any suggestions please.

  Stuartli 10:37 08 May 2007

Do you have two optical drives?

You probably are using the E rather than D drive (depending on the drive lettering and number of drives).

  Greengage 10:45 08 May 2007

Yes, two drives. Had been using D but in light of your response I have tried E but with the same result.

  Greengage 12:25 08 May 2007

Thanks for your help, Stuartli, but it looks like I'm going to have to do a Repair install again.

  Graham. 14:07 08 May 2007

I can't reproduce this at the moment, but do you get the option of browsing to the disc? Sometimes that works.

  Stuartli 14:08 08 May 2007

This is probably the information you are thinking of from previous forum answers:

click here

  Stuartli 14:09 08 May 2007

All the WindowsUpdates can be downloaded in one go from:

click here

choosing the relevant latest version.

  Greengage 15:08 08 May 2007

I have just completed doing a Repair Install of XP Home. Following that, I tested sfc /scannow again and I am receiving exactly the same messages. I have been back into the Registry to check Source Path and have also followed your links Stuartli (before I started I had downloaded the full & updates from Autopatcher but have not yet installed). Graham - I do not get that option.

I cannot understand what is going on.

  TOPCAT® 15:38 08 May 2007

Having copied i386 to the C drive, did you change the drive path on two entries in the registry. - both SourcePath and ServicePackSourcePath to C: ?

click here for sfc /scannow info on this. TC

  Greengage 16:13 08 May 2007

Thank you both for the further suggestions. I have been back into the registry and the drive path for SourcePath and ServicePackSourcePath are the same (got it back to D drive for now) and I have also checked that WindowsNT\CurrentVersion\SourcePath (as suggested in the above link) is also the same. I checked the registry on my laptop for the three items and noticed that SourcePath on the latter was D:\I386 so changed it to that on the PC. Tried scf /scannow again but still no go - I'm still getting the same messages. The laptop has no problem with its settings.

  TOPCAT® 16:39 08 May 2007

and came up with this: click here

It could be that Sandra needs repair so here's some possible answers to the message(s) you get when you try to run it. I hope it helps. TC.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?