Severe Problem with new PC

  douglegs 14:19 03 Jan 2005

We have a one month old HP Pc, running Windows XP SP2. Everything was running great until the other day. We made several changes to the system last week and things seemed fine until I booted it up the next day. Firstly we added an ADSL gateway... everything was fine, my partner was able to wirelessly access the network too. I then networked our HP Photosmart 2610 all-in-one to the second ethernet port on the gateway. At this point I was told to shutdown the Norton firewall which we have installed. I am concerned that at this point something has infected the PC. On start-up of the pc i am receiving a message saying that the

Generic Host Process for WIN32 services has been shut down to prevent security exploits. When trying to open an IE Browser window I have to wait ages, before a pop-up comes up to say:

svchost.exe- Application Error. The instruction at 0x009a96bc referenced memory ar "0x00000000" The memory could not be "written".

I have uninstalled the printer drivers, disconnected PC from the network and reverted to standard single-pc adsl modem but to no avail. I have run a system scan with Norton but it says all ok...

I scanned with an adware problem that needs to be purchased which said that there was a severe problem with C:\windows\prefetch\regsvr32.exe I am not sure if this is related, or if they are trying to get me to buy their product to fix something that is not an issue???

Can anybody give me any guidance on this? PS We also loaded a licensed version of Office 2003 and carried out all windows updates on this day, including NET 1.1 services??


  Starfox 14:31 03 Jan 2005

System Restore (if not already done so)

  Belatucadrus 14:40 03 Jan 2005

Be very wary of 'Free' adware programs that report problems on the free scan and then require payment to clean them, most of them are using scare ware and false positives to get you to pay for their product. Stick with Spybot click here or Ad-Aware SE personal click here both are genuine freeware and as good as anything on the market.

  Fruit Bat /\0/\ 14:40 03 Jan 2005

The Prefetch folder is used by Windows XP to speed the boot process. Windows XP records information about each program that launches at boot and uses that information to boot faster the next time. Because multiple files might have the same name, it appends a "hash" of the file's location. That's the odd string of numbers and letters between the filename and the .pf extension.

This folder may accumulate useless junk, especially if you change your configuration a lot. There's no harm in emptying it. Simply delete all the files in that folder; Windows will rebuild it as needed.

  douglegs 16:24 03 Jan 2005

I have now tried both Spybot and Ad-Aware SE and only tracking cookies have been found.

I tried a system restore yesterday and took it back to the point before networking the printer.

I am concerned that this might not be an incorrect setting but possibly a worm? Norton nor AVG can find anything.

  Fruit Bat /\0/\ 16:31 03 Jan 2005

Anything in the prefetch folder is not a problem delete it if unhappy.

  herc182 16:37 03 Jan 2005

if you are still worried about it being a worm then

click here

run this. it should find any pests....

  douglegs 17:41 03 Jan 2005

I have emptied the prefetch folder and I have also tried the other malware checker above but nothing has been found. The Generic host Process error message contains this information if it helps???

In task manager I have 6 instancs of svchost running. The problem also only becomes aparanent when using windows exploer / my computer, or internet explorer...

EventType : BEX P1 : svchost.exe P2 : 5.1.2600.2180 P3 : 41107ed6
P4 : unknown P5 : P6 : 00000000 P7 : 009a96bc
P8 : c0000005 P9 : 00000008


  douglegs 20:05 04 Jan 2005

After looking on the Microsoft site for more information on the WIN32 Services error message I discovered that other people were having the same problem as me... It turns out that it was the software driver for the HP2610 printer that I had just installed (well, re-installed for network setup rather than direct USB). HP have a critical update on their site. I have completely uninststalled the driver (something which system restore did not do) and reinstalled the latest version, followed by the critical update.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?