Service Pack 3 update;TROJAN?

  gnvqsos 13:39 14 Jun 2010
Locked

I updated my PC(XP)using the MS site and downloaded SP3.I believe I may have a trojan I cannot run Malwarebytes etc as they are blocked and Avast is poorly.When I tried system restore I end up with file dll32.exe.
I would be grateful for any advice.Moreover the taskm manger is not working properly.CAN I run a cd with antispyware etc through my PC to eliminate problem?Thanks in anticipation

  robin_x 13:44 14 Jun 2010

Could try SuperAntiSPyware. Also now has a portable download I believe. (put on a flash card/stick)

click here

  robin_x 13:48 14 Jun 2010

Also try Avira free at avira.com.

My SP3 is

WindowsXP-KB936929-SP3-x86-ENU.exe (300+ MB)

Google it, but you may have had your infection beforehand.

  birdface 13:51 14 Jun 2010

This program should be able to remove some of it.
Enough of it to then update your other security programs.
If it does not let you update it run it as it is.

click here

  johndrew 13:55 14 Jun 2010

I agree with robinofloxley that it may have been a pre-existing infection. However many people had problems with the SP3 installation when it was released and one method found was to install in Safe Mode.

My download of SP3 is the same as above.

  T I M B O 13:56 14 Jun 2010

Another goodie>> click here

  T I M B O 14:02 14 Jun 2010

Normally b4 a service pack is installed, it will do what's called an "mrt" scan, but this scan all depends on if you have all the critical updates. Problem maybe of course that it's been sometime since SP3 was released.

Just an insight>> click here

To run mrt click start & go to the "run"
Type in mrt & follow the rest of the prompts.

  gnvqsos 07:02 15 Jun 2010

I nhave tried the Malwarebytes,Spybot and Dr Web but none has detected virus.I have found adware using Superantispyware but the scan does not complete leaving PC and mouse in frozen state.Please give further advice please

  birdface 07:32 15 Jun 2010

Try running your security programs in safe mode.
Just keep tapping F8 as the computer starts.
Or if system restore works in safe mode restore your computer to a time before you downloaded SP3.

  gnvqsos 07:50 15 Jun 2010

Thanks for the advice Buteman.I have used F8 to get to safe mode.How do I then access my AV programs from safe mode?Do I have to press enter and then start and run my Avast AV?Thanks for your help so far
John

  birdface 07:54 15 Jun 2010

Some of the problems it causes.

click here

If it is using up a lot of the CPU in Task Manager maybe disable it and see if your security programs work any better.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017