Serious Code 39 issue

  Huntressdi 03:42 08 Mar 2009

Let me start by saying any help is greatly appreciated. So check out the following scenario and see if you can help:

I was in a hurry and I wanted to optimize my system so I was using a piece of software called nCleaner and it works but as I was in a hurry I didn't check as I should have what I told it to do (so that's my fault). Anyway I realised something was wrong and stopped the program and realised that it was removing the shortcuts from the start menu. I couldn't do anything right away as I had to leave. I came home and the system started up ok but while I looking around at the damage I had inadvertently caused I realise that the DVD Rom wasn't showing up at all. Figuring it was a mistake I rebooted my system hoping that the computer would pick up the DVD rom. It didn't. In fact the computer is telling me now that it has a floppy drive when actually it doesn't have one.

Since then whenever I start the computer, startup fails so it automatically reboots and I actually see a BSOD but it disappears so quickly that I can't read what it says. I know enough to press F8 to get to the last known good config and that's how I start the computer.

Based on my research, I checked the device manager and saw that it's reading dvd drive but it's giving me a code 39. I tried deleting the lower filters and upperfilters but because of the BSOD and the fact that it keeps restarting. the deletion isn't having the desired effect. It's a Pioneer DVD Drive, I looked for the drivers on their site but I found firmware instead. I also searched other sites for drivers and found them but they're not installing or give me an error.

I do have my win xp CD but I have stuff on my comp that needs to be backed up but right now I have no way of doing that, though I'm thinking of trying to get hold of a 4Gig or 8Gig USB flash drive to do the back-up.

According to Microsoft, the reasons for a Code 39 errors are as follows:

* A required device driver is missing.
* A required binary file is corrupted.
* There is a problem with the file I/O process.
* A driver that is referencing an entry point in another binary file is unable to load.

So suggestions are greatly appreciated.

  crosstrainer 07:34 08 Mar 2009

Start your PC in safe mode (tap the F* key repeatedly on bootup)

If the PC starts, go to system restore, and choose a restore point BEFORE you ran ncleaaner...Must say I have never heard of this utility...Will look around.

  crosstrainer 07:36 08 Mar 2009

Seems a little low in most peoples estimates:

click here

I would remove it and substitue ccleaner:

click here

  skidzy 09:52 08 Mar 2009

Can you boot into safemode with networking ?

if so,download and run this click here

But as Crosstrainer has said,system restore is your best bet first.

  Huntressdi 02:11 09 Mar 2009

First let me start off by saying Thank you for the suggestions however neither of them worked for my situation but I'm sure they would in someoneelse's. What did work was step 4 on a solution page suggested by someone on another forum I'm on. So I'm gonna share because it's the right thing to do and it just might help someone else. So check out this link below:

click here

My only problem now is that my pc is still telling me that it has a floppy drive when in fact, it doesn't exist. So if you know the fix for the floppy drive issue, once again it would be greatly appreciated.

  crosstrainer 07:27 09 Mar 2009

Go into your BIOS and disable floppy drive from there.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse's new logo: the trainer brand looks to its heritage for a fresh identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?