Serial Port Modem Problem

  ensonricky 15:35 29 Mar 2005
Locked

I am attempting to access an internal SmartLink 56K Modem in my Advent 7026 laptop running Windows XP Home Edition I connect tothe internet wirelessly using a Netgear 834G ADSL modem router. When I query the smartlink modem I get the error message 402 'OpenPort' the port (Com3) is already open.

No com ports are listed in device manager, only the printer port, and if I select view hidden devices I notice there is a yellow exclamation mark next to the serial port driver. I don't Know if this issue is related to my modem problem. The modem and serial port have both been uninstalled/reinstalled and the latest modem drivers have been employed.

I have also closed any other applications that I consider may be using the port in question. I have also tried using other com ports that are listed in the modem's software.

Can anyone suggest any options that I haven't considered.

Thanks

  Fingees 15:46 29 Mar 2005

I don't quite understand whether you are trying to use two modems. Certainly an asdl router will not be compatable with dial up.

The exclamation mark means there is a fault with the serial port. it will have to be uninstalled, the computer rebooted, and XP will instal drivers for the port.
However, check you have the latest drivers for the modem. but don't insal them until you see the serial port listed without exclamation mark

  ensonricky 15:55 29 Mar 2005

Thanks for your response. I don't wish to use both my broadband connection and dial up at the same time but will require a dial up connection to access my work account whist away from home.

As explained I have already uninstalled the serial port but on boot up the drivers that load do not resolve the issue.

  Fingees 16:00 29 Mar 2005

As your internal modem does not show in device manager, have you tried opening control panel and searching for new hardware?

  Fingees 16:15 29 Mar 2005

It's me again,
I suspect the serial port referred to is your modem, I forgot you were using a laptop that presumably has no actual serial port.

So as mentioned. uninstal via device manager, ask to search for new hardware in control panel, and go from there.

XP should recognise there is a modem there.

check however in phone and modem in control panel, that it's not already listed. If so, remove it and start again.

  ensonricky 16:50 29 Mar 2005

Just to clarify the SmartLink 56K Modem does show in the device manager it's the com ports that don't display under 'Ports' in device manager, the modem just seems unable to access the com ports because they always show as open.

My only concern regarding the Serial Port issue was that is may be contributing to my modem problem.

  Fingees 16:57 29 Mar 2005

Ok.
It's quite possible that the port is open at all times as the modem is always installed. Remember the port is the input to the modem, not the output.
have you actually tried to connect to phone line and dial up?

  ensonricky 17:24 29 Mar 2005

No joy whilst connected to the phone line, the open port isue still seems to prevent me establishing a connection. By the way I have no problems connecting when using my internal modem that I have in my desktop.

  ensonricky 17:32 29 Mar 2005

Thanks for that, any ideal what other software/Hardware may be accessing the port.

  ensonricky 18:35 29 Mar 2005

Any more ideas please.

  ensonricky 20:41 29 Mar 2005

Bump

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone