Self Registration Error

  barryc61 10:21 16 Apr 2004

Despite several attempts to install a program called AutotraxEDA on a computer running XP Home I get the following message -
Self Registration Error
One or more files did not self register. The following files did not self register ...

C:\Program Files\Common Files\System\OLE DB\oledb32.dll

To continue select OK otherwise select Cancel
A similar message also comes up flagged against MSDASQL.DLL

I have tried running regsvr32.exe against OLEDB32.DLL & MSDASQL.DLL using the
Command Line Prompt C:\ in a DOS screen, the message I receive states -

The specified procedure could not be found

Any ideas on my next move anyone please?

NB: Files ole32.dll ole32dbr.dll OLE32DBX.DLL & msdasql.dll & msdasqlr.dll
are actually present in C:\Program Files\Common Files\System\OLE DB

  AndySD 11:04 16 Apr 2004

At a command prompt, change to the C:\Program Files\Common Files\System\Ole DB folder.
At a command prompt, type the following command:

regsvr32 sqloledb.dll

You should receive confirmation that the DLL is registered successfully.

Then the others

  barryc61 15:32 23 Apr 2004

Hi Andy, thanks for your input. Unfortunately still does not work ... done a search for sqloledb.dll and found two copies - one of 460Kb in c:\WINDOWS\SevicePackFiles\i386 with file date 12/07/2002, the other c:\Program Files\Common Files\System\Ole DB and 492Kb, file dated 20/02/2003 ..........

When I run your suggested line, screen reverts back to windows (XP) with the message

LoadLibrary("sqloledb.dll)failed - the specified procedure could not be found.

Any other ideas please. Also, if it had worked would that have been it, or would I always have to carry out this procedure at every program upgrade.

  AndySD 11:00 24 Apr 2004


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?