Secondary hard drive disappears from windows after sleep mode

  Olii999 12:25 05 Oct 2011
Locked

Whenever my computer goes into sleep mode and then wake it up again the secondary hdd has disappeared. It always re-appears and works fine after a re-boot so don't think there's a problem with the drive. I have temporarily resolved the problem by disabling sleep mode but would like to re-enable it for power saving purposes. Please does anyone have any ideas how to resolve this problem?

My machine is a dell inspiron running windows 7 64-bit.

  northumbria61 12:40 05 Oct 2011

First thing to try -

I think there may be some problem in your motherboard and hard-disk connection and that's why you are getting such type of problem. In this case just disconnect your computer from the power and then disconnect your hard-disk from your computer and then re-connect it again. After that plug your computer to the power and turn on your computer. You should find that this has resolved your problem.

  Secret-Squirrel 12:47 05 Oct 2011

"secondary hdd has disappeared.......My machine is a dell inspiron..."

Because you've got a laptop, I'm assuming this second drive is an external USB one - is that correct? If it is then I've got an idea or two for you.

  Olii999 12:53 05 Oct 2011

It's a desktop and it's an internal SATA hard drive that is causing the problem. I do have an external USB drive as well but there are no problems at all with that.

The connection to the motherboard is fine. It happens consistenetly when the computer goes into sleep mode otherwise the drive works 100% fine.

  robin_x 13:04 05 Oct 2011

Check the disk Properties in Device Manager for any Power options (just checked mine, there are none)

If W7, check Advance Power Options Disks (Turn Off after...)

Check the disk Manuafcturer's website for your model and any info/utils. My Seagate Barracuda has it's own sleep mode, for example.

  northumbria61 15:03 05 Oct 2011

You could also check in Event Viewer to see if you a Disk Error Event ID

  northumbria61 15:05 05 Oct 2011

You may find you have Event ID 11

  Olii999 23:01 05 Oct 2011

Cehcked the event view and there are some event ID 11 errors in there but none in the last 24 hours even though I re-created the problem twice today.

  Olii999 23:02 05 Oct 2011

have tried chaning the advanced power options for the hard disk to switch off after 100000 minutes from 20 minutes but that didn't make any difference.

  northumbria61 23:27 05 Oct 2011

Event ID 11 may be related to the device controller - I noticed that you said the issue occurred with both secondary SATA hard drive and I recommend you to re-enable the typical, or faster, transfer mode for an affected device:

1.Press Win + R to launch a run box. 2.Type: compmgmt.msc and hint Enter. 3.Double-click Administrative Tools, and then click Computer Management. 4.Click System Tools, and then click Device Manager. 5.Expand the IDE ATA/ATAPI Controllers node. 6.Double-click the controller for which you want to restore the typical DMA transfer mode. 7.Click the Driver tab. 8.Click Uninstall.

When the process completes, restart your computer. When Windows restarts, the hard disk controller is re-enumerated and the transfer mode is reset to the default value for each device that is connected to the controller.

  Olii999 18:27 06 Oct 2011

turns out this is a known problem with Windows 7 and large SATA drives. Microsoft have released a hotfix for it.

http://support.microsoft.com/kb/977178/#top

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone