Second Hard Drive Not Registering, please help

  User-DC54739E-C813-411C-8F17BC64846610C4 08:52 12 May 2009
Locked

Hi guys, really hope somebody can help...

I've had an issue the past few days with re-installing a new OS, but eventually solved it by purchasing Windows Vista Home (I know, who'd have thought it would be easier doing that?!).

I now have a strange problem...I've got two hard drives in my PC - both Maxtor. One is 80GB and has Vista on it, the other is 200GB. Something strange has happened, though, in that the second - 200GB hard drive - is no longer registering in BIOS or showing up in Vista.

I've checked, by messing around with cables, that the hard drive is recognised in BIOS if I put it in on it's own, as the master drive - and it does. However, when I put it back in as a slave drive with the 80GB one, it no longer shows. I've checked all the jumper settings.

I wondered if it might be the cable, so I plugged a DVD Rom writer into the cable, and it didn't show. So, that was that - it was clearly the cable...or so I thought! On a whim, I put the DVD writer as the master, and the 80GB with Vista as the slave. Both of them showed up correctly in the BIOS, and in Vista.

I tried putting the 200GB HDD onto the 2nd IDE cable, but no joy - either set as a master or a slave.

So, to sum up, the 200GB HDD works and appears in the BIOS if it's set to master and is plugged in to the 1st HDD cable on it's own.

The 80GB HDD works and appears if it's set to master OR slave and plugged into the 1st HDD cable.

The DVD writer doesn't show up if it's set to slave, but will show up if it's set to master, on the 1st HDD cable with the 80GB HDD.

Does anybody PLEASE have any idea how to solve this? I figure the cables and the port, certainly for the 1st HDD are working, as the 80GB is happy to show up as either master or slave. Why, though, is the 200GB showing up only as master?

Could it be that some of my motherboard drivers are wrong, or missing? I've checked all the jumper settings are correct on each drive whenever they're plugged in as either master or slave.

Has anyone had this problem before, and can they help?

Thanks, really appreciate the advice, and apologies for the long post.

Andy

  Diemmess 10:26 12 May 2009

Without perhaps really thinking about it, and assuming you are using 80 wire data cables.......
....Have you tried the 200Gb or even both HDs set to CSL and both on the same data cable?

Thanks

I've tried them both on the same data cable, but not either or both set to CSL, just set to Master and Slave...you think that might do the trick?

  Diemmess 11:56 12 May 2009

I'm no guru on this one, but in the past I have used the same sort of hardware (IDE and 80 wire data cable) and CSL seems to be the setting, particularly of any secondary HD.
The computer then sorts it out for itself

Ok, thanks, I'll give it a try

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017