Second Hard Drive not recognized.

  DannyOH 23:00 29 Jan 2005

Hi Guys,

The following problem has occurred with my Windows XP Pro re-installation, but a web search (use search term: "hard drive not recognized") reveals that it also has occured with many other versions of Windows. Judging by the amount of resultant misery out there, it appears that no one--including Microsoft--has a solution either!

I have a SATA main drive, with TWO backup ATA100 drives, master and slave, on a Promise Ultra 100TX2 RAID controller. All is set up as before, and which never before gave me any trouble, even through numerous reinstalls. Note, that the plethora of web discussions on the subject indicate that the problem is also occurring on various other, more straightforward, Windows systems--98, NT, etc.--as well as with CDROM and DVD drives and floppy drives too.

Having first disconnected my two backup drives (with all my personal data on them) I have just reformatted my C: drive and reinsalled Windows XP Pro. Shutting down and disconnecting the power, I then reconnected my two backup drives before restarting.

The two backup drives appear in Device Manager.
They are listed as "working properly"
they DO NOT SHOW UP in "My Computer".

You can take it as read that the jumpers are set correctly. As I have just replaced the cables with new ones, they too are good. Neither did uninstalling and reinstalling the drives solve the problem. The normal procedure of changing or assigning a (new) drive letter in Disk Manager also does not work--since all the variety of options are rendered unavailable. Out of the full Right Click menu, the only available options are "Delete Partition"--I'm certainly not going to do that--and "Help", which offers no help at all. All the usual solutions, in fact, have proven useless to me--as to everyone else out there in this situation.

I have employed Maxtor's PowerMax utility. No joy there.

I SUSPECT: the problem may have originated through duplicate drive letters.

My two backup drives had before been, D: and E: (with their several partitions known by higher letters.)

Since the reinstall and partitioning created partitions C: D: and E: on the main drive, perhaps (shades of "HAL" here) Windows may have become "paranoid"--not knowing "which" D: and E: are the "real" ones.

Whether this is the problem or not, I don't know. I only now that I have tried all I can think of to change the drive letters, and to access the data, even in a DOS environment, but cannot.

Despite all, the drives are still listed in Drive Manager as "Healthy (Active)" --which is all that is keeping me sane at the moment, worrying if my data, while not (yet) available, is still viable.

Problems don't get more serious than this, guys.

I can't opt out of this one. There's a lifetime of work at stake here.

All the best to all,

  Fruit Bat /\0/\ 23:20 29 Jan 2005

Do the drives show up in Control panel- admin tools -computer management - disk managenet?

  Baz48 00:28 30 Jan 2005

Do they show up in the BIOS?

  temp003 07:41 30 Jan 2005

I can't rule out drive letter conflict, but normally XP should be able to reassign drive letters, even where the additional disk had a previous OS on it (incl XP itself).

I have noted that the IDE hdds are shown in Device Manager and in Disk Management, so that BIOS setup and jumpers are unlikely to be the cause of the problem, but can you just double check them? Sometimes these things work in inexplicable ways. Make sure jumpering and cables are correct, hdds and disk sizes are properly detected in BIOS, RAID is not enabled.

In Disk Management, bottom half, are the disks shown as disk1 and disk2?

On the left, do you get (1) basic (2) approx. correct disk sizes (3) online?

On the right, are the previous partitions shown, with correct partition sizes - just no drive letters? Or are the previous partitions not shown at all.

If any of the above is amiss, can you post back?

Did you ever have Goback installed, or some other program which may have re-written the MBR? If so, where was such a program installed, on the SATA drive or on one of the IDE hdds?

  FelixTCat 09:51 30 Jan 2005

Did you load the raid controller drivers? You may need them even if the disks are not set up as Raid 0 or 1. The reference to "Delete Partition" in Disk Manager makes me think it believes they are in raid formation.

Try plugging the ATA drives into the ata controller, not the raid controller if they are not set up for raid.

Are you sure that the D: and E: partitions are from the SATA drive? Windows normally issues drive letters to primary partitions first, then logical drives on extended partitions.

  DannyOH 16:14 30 Jan 2005

Yes. The drives show up in both Device Manager ("Working Properly" -!) and in Disk Management where they are listed as "Online" and as "healthy (Active)". But that is all. They do not show up in My Computer and so, are efectively non-existent. As the facility to change the drive letter is not available, these drives cannot be accessed.

I have just updated the BIOS, by the way, to the latest version--to no avail. The drives do show up in the BIOS, but as the setting of drive parameters is automatic, there is no facility there that I can see for setting them manually. (The motherboard is an Asus A7V880.) The only thing I can do with the drives in the BIOS is set one as having priority over the others--just like CD/Floppy priority.

As for checking jumpers etc, this I have done quadruple times, and anyway, these have not changed since previous installations. I am falbbergasted that the installation should suddenly have developed such an ominous foible totaly out of the blue. "Inexplicable" indeed. Kind of upsets the premise that, within a given set of parameters, computers always do EXACTLY the same thing each time, forever.

TEMP03: I am confused by your query, "raid is not enabled?" As both these drives are on a Raid card, this sounds like an avenue I can investigate. And yes, the C: drive is shown as disk 3, while the two problem disks are DISK 1 and DISK 2. (This is significant???) To tell you the truth, RAID has always somewhat mystified me. Windows installed the RAID drivers automatically and I left it at that. Always worked before. Nevertheless, I uninstalled the Windows-supplied RAID driver and used the Promise-supplied Floppy to reinstall it. I presume that is kosher--but it still didn't work.

And yes again, on the left for backup Drive1 is: Disk 1, Basic, Online, and the correct size is indicated. The same is true for Disk 2 backup drive. (Always thought it peculair that the System drive should be listed as Disk 3.) On the right, there are no partitions indicated for either of the backup drives, but the disks are--or were--partitioned.#

Roxio's GoBack? HMMMM! Funny thing, that. And here we have a genuine differential. Yes it was installed, on the main SATA drive--but it was never used to "go back". This being the first time I installed GoBack, it is also the first time I have had-or heard of--this problem. GoBask however is not now installed, and I am working off a fresh new installation--WinXP, SP2, and nothing else.

D: and E: are listed as "logical" partitions on the main, SATA, drive. D: and E: appear again however (one as D: and one as E:) as sole visible partitions on the backup drives. I know this can't be right.

Taking the backup disks off the RAID controller and puting them (one at a time) onto the ATA (master) will be my next move--but others with this problem have done that and it did not work for them, so I don't hold out much hope. Will let you know in a bit.

  DannyOH 16:56 30 Jan 2005

I now have on my system, one main hard drive on SATA1, and one ATA100 backup drive (set to ("master") now on IDE2, (with no slave).

Disk Management shows the following:

DISK 0: Basic, 19.08GB (correct), Online, Healthy and Active. As Drive E:, it indicates (incorrectly) one Primary partition where there should be three partitions.

DISK 1: Basic, Online and Healthy and Active, 76.33Gb (correct). As Drive C:, it also (correctly) indicates two logical partitions, X: and Y:.

All the menu options--including Change Drive Letter--are available for the SATA drive (Disk 1), but not for the ATA/IDE backup drive (Disk 0). Change of drive leter is not available.


  Storik 17:24 30 Jan 2005

Why not go into Device Manager and "remove"/"delete" ALL the hard drives and reboot your machine. Windows might pick them up at reboot.

If the above doesn't work, you could try either changing your BIOS to default and resetting it, or clearing it completely via the jumpers and resetting it.

I don't know whether these suggestions will help, but they just might.


  Storik 17:27 30 Jan 2005

Are any of your partitions larger than they were at previous installation? Does WinXP have some kind of limit to the size of hard drive, whether virtual or logical?


  FelixTCat 19:07 30 Jan 2005

Do you have another computer, or a friend, where you could install the unrecognised drives? That would give you an idea as to whether the problem is with your computer or with the drives.

  Spark6 21:27 30 Jan 2005

'Since the reinstall and partitioning created partitions C: D: and E: on the main drive, perhaps (shades of "HAL" here) Windows may have become "paranoid"--not knowing "which" D: and E: are the "real" ones.

Whether this is the problem or not, I don't know.'

If your problem is due to the partitioning and idents of same, would it be possible to reinstall the main drive temporarily without partitions?

Forgive me if you have already discounted this or if it is impractical.

Best of luck.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros