SD Card problem

  Les 08:05 11 Dec 2007

I have a problem with a new Sandisk 2 GB. SD card. The built-in Card Reader on the computer will not access the card ( telling me that the card is not formatted – trying to do so creates a error, ie: cannot format the card)- but , if I put this card into a portable card reader plugged into the front mounted USB ports it is read with no problem. With the card in the camera and connected by USB – it is accessed.

The 1GB card which came with the camera causes no problems whatsoever, either directly into the machine’s card reader – or from the camera via USB.

Any ideas on what is going on would be appreciated.

  jack 08:41 11 Dec 2007

The built in reader. did this have a software on the utilities disk that came with the computer?
If so it may need configuring.
Other than that there must be some limitation within the firmware of the unit.

  Les 10:34 11 Dec 2007

No, it didn't have any software with it and has, up till now, worked perfectly. In fact it does read the 1 GB card that came with the camera. The camera reads the 2 GB card.

A further puzzle is that my PVR has a card reader and this reads the 2gb too - but - as you may know the camera puts folders and sub folders on these cards - I have created (whilst the card was in the USB card reader) new folders containing photos. After the first two or three folders I tried the card in the PVR and these showed up on screen, I added further folders , tried it agian in the PVR and none of tghe folders showed at all - a mystery!!

  Les 10:44 11 Dec 2007

The PVR problem has been solved. The original folder shows first, the other folders (all at the same level as the original) don't show until you right click on the remote - then they appear - curious!

Nevertheless, the problem of why the card reader will read the 1GB but not the 2GB remains a mystery. Via USB it is read.

  jack 10:22 13 Dec 2007

It has to be a limitation in the firmware of the built in reader I would think- might there be an burnable update available from the maker/source?

  Les 19:08 13 Dec 2007

After the last post I noticed that my card reader had stopped working, also the USB wasn't listing under folders in Explorer. Some three weeks ago a 'worm' was reported by Spyware Terminator and subsequently quaratined - and, of course Mirosoft downloaded patches on Wednesday morning. Possibly one of these caused the problem - I don't know. Anyway, I decided that the worm was still present and decided to do a 'recovery' using the disc supplied by Evesham. This began by doing a format of the 'C' Drive - Ok, that's alright if a worm had corrupted files. The recovery ran for half an install and then entered a loop doing the same thing again! I tried to restore an image off my external drive (should have done that first 8-(( ) - this began by telling me that it would take nearly 2 days to restore ! I think that, at this time, that the external was working as if connected to USB l - not USB 2. Anyway, I tried again, this time only restoring the Windows folder, this took just over 4 hours. The message Invalid Partition Table came up. I then restored the full image of the C drive and, to my relief, it quoted 2 hours nnd I know that this was the correct figure - true to the time given it successfully restored the whole image and again, to my great relief, the computer booted correctly.
Just in time - the kids would have been very upset if they couldn't have had their daily dose of MSN Messenger!

I have yet to try the card - this I will do when I have checked everything else.

Thanks for your replies - I'll post the result - hopefully, they will be positive 8-))

  Les 21:26 13 Dec 2007

SD Cards are not recognised by the card reader whilst a Sony Mediastick is.

Connecting the camera by USB and they are recognised and files can be transferred to/from the cards.

The Panasonic PVR recognizes them too.

I guess that I will have to be satisfied that I can extract the data from them, not so conveniently but it works <g>

  Strawballs 22:11 13 Dec 2007
  Les 22:41 13 Dec 2007

Ah! Strawballs, I think that, as my card reader/computer is over 3 years old that this is the answer. 2 Gigs didn't exist then. The Memory stick is a 512 mb one. Also perhaps explains why the card, in an external USB card reader worked.


  Strawballs 00:24 14 Dec 2007

It seems to be a common problem, I might try and see if there is a firmware upgrade for the one in my lappy.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?